felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Leangen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5338) Clarification of Converter.getAdapter()
Date Thu, 08 Sep 2016 07:33:20 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5338?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15473095#comment-15473095
] 

David Leangen commented on FELIX-5338:
--------------------------------------

Cool, thanks! :-)

> Clarification of Converter.getAdapter()
> ---------------------------------------
>
>                 Key: FELIX-5338
>                 URL: https://issues.apache.org/jira/browse/FELIX-5338
>             Project: Felix
>          Issue Type: Improvement
>          Components: Converter
>            Reporter: David Leangen
>            Assignee: David Bosschaert
>
> Hi!
> The intent of Converter.getAdapter() is not quite clear to me.
> {code}
> 	/**
> 	 * Obtain an adapter to this converter. The adapter behaves just like the
> 	 * converter except for the exception rules registered with is. For more
> 	 * details see the {@link Adapter} interface.
> 	 * 
> 	 * @return An adapter to this converter.
> 	 */
> 	Adapter getAdapter();
> {code}
> Is this supposed to return an *existing* Adapter? Or rather, should it return a *new*
Adapter.
> My guess is the latter, and the implementation code aligns with my expectation. However,
it is not clear from the documentation or the API.
> Suggestion: the method should be renamed to "newAdapter()".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message