felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Engström (JIRA) <j...@apache.org>
Subject [jira] [Commented] (FELIX-5219) Servlet Bridge does not work if not mounted as root servlet
Date Sat, 19 Mar 2016 11:04:33 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5219?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15202720#comment-15202720
] 

Anders Engström commented on FELIX-5219:
----------------------------------------

Ok - I need to look closer at the integration tests then :) Good to know that they are there
as an extra safety net.

I've created a custom integration test (maybe unnecessary) where I start an embedded Jetty,
deploy the required event listeners and the proxy-servlet. One event listener starts an OSGi
context and deploys the bridge and some dependencies. I use this to verify my changes.



> Servlet Bridge does not work if not mounted as root servlet
> -----------------------------------------------------------
>
>                 Key: FELIX-5219
>                 URL: https://issues.apache.org/jira/browse/FELIX-5219
>             Project: Felix
>          Issue Type: Bug
>          Components: HTTP Service
>    Affects Versions: http.proxy-3.0.0, http.bridge-3.0.0, http.bridge-3.0.2, http.bridge-3.0.4,
http.bridge-3.0.6
>            Reporter: Anders Engström
>
> As described in the email thread http://www.mail-archive.com/users%40felix.apache.org/msg17074.html
-- the Http Servlet Proxy/Bridge does not work when binding the Proxy Servlet something else
than {{/*}}.
> It seems that the bug was introduced in the 3.* versions - the proxy/bridge works as
expected with version {{2.3.2}}.
> I've created a reference project at https://github.com/metamorph/http-osgi-bridge that
demonstrates the bug.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message