felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5105) Web Console configuration does not appear in configurations
Date Mon, 23 Nov 2015 14:19:10 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5105?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15022142#comment-15022142
] 

Carsten Ziegeler commented on FELIX-5105:
-----------------------------------------

Adjusting the default values before the edit form is created makes the metatype only correct
in the case of the web console. if any other tool is using the metatype it will get the wrong
default values.

I'm using org.apache.felix.metatype (1.1.2) - I'm wondering if a package refresh solves your
problem as well?



> Web Console configuration does not appear in configurations
> -----------------------------------------------------------
>
>                 Key: FELIX-5105
>                 URL: https://issues.apache.org/jira/browse/FELIX-5105
>             Project: Felix
>          Issue Type: Bug
>          Components: Web Console
>    Affects Versions: webconsole-4.2.14
>            Reporter: Miroslav Ć ulc
>              Labels: patch
>         Attachments: metatype.xml.patch
>
>
> since some time web console configuration is more and more broken it seems. there is
for example bug related to lost localization of the configuration which i encountered on my
installations too. in some cases it also happens that the web console configuration is not
displayed at all. in fact i was not able to display it (and so edit it) at all. i tried to
debug the issue but the only thing i found is that for some (to me) unknown reason the configuration
from java class is not picked up.
> in version 4.2.15-SNAPSHOT and older versions the metatype provider is implemented as
java class org.apache.felix.webconsole.internal.servlet.ConfigurationMetatypeSupport. that
is probably the cause of the problem that the configuration usually does not load, maybe because
of some synchronization issue. i noticed some information about attempts to fix it in previous
versions of web console but these were just attempts as the issue persists.
> i have no idea why the metatype provider is implemented using ConfigurationMetatypeSupport
class instead of using metatype.xml file which would be more transparent and easier to manage,
maybe it's for historical reason when metatype implementation was not that capable as it is
now.
> so i created metatype.xml file that defines the same configuration as is done using ConfigurationMetatypeSupport
and it seems to work fine. i did not remove the ConfigurationMetatypeSupport and related code
though as i guess it would be better done by someone who better understands the code.
> i will try to attach the patch i have if i find out how.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message