felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: Minimum Java version for resolver and framework?
Date Sun, 26 Jul 2015 19:19:00 GMT
No, that's definitely not the intention.
I have been working with JDK 8 and I missed this error.
We can set up the animal-sniffer maven plugin to make sure we only use
allowed signatures.

2015-07-26 9:53 GMT+02:00 Carsten Ziegeler <cziegeler@apache.org>:

> Am 25.07.15 um 17:51 schrieb Jean-Baptiste Onofré:
> > Hi Carsten,
> >
> > I just built resolver trunk (1.5.0-SNAPSHOT) with Java 1.8 and Maven
> 3.2.5.
> >
> > What's your issue ?
> >
> Right, it works with 1.8, but it doesnt with 1.7:
>
> I get two compilation failures like this:
>
> resolver/src/main/java/org/apache/felix/resolver/util/ArrayMap.java:[100,46]
> <anonymous org.apache.felix.resolver.util.ArrayMap$1$1> is not abstract
> and does not override abstract method remove() in java.util.Iterator
>
> so this code really requires Java 8 (default methods in interfaces).
> I guess this is not the intention?
>
> Carsten
> --
> Carsten Ziegeler
> Adobe Research Switzerland
> cziegeler@apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message