felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: Minimum Java version for resolver and framework?
Date Mon, 27 Jul 2015 06:08:06 GMT
Am 26.07.15 um 21:19 schrieb Guillaume Nodet:
> No, that's definitely not the intention.
> I have been working with JDK 8 and I missed this error.
> We can set up the animal-sniffer maven plugin to make sure we only use
> allowed signatures.

Unfortunately, this already fails right now before the animal sniffer
plugin runs as its a compilation error :)

Interestingly, when building with java 8, the animal sniffer plugin runs
and checks against 1.5, but does not find the problem as I guess the
resulting classes contain the missing methods.

Carsten Ziegeler
Adobe Research Switzerland

View raw message