felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arindam Bandyopadhyay (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FELIX-4808) JDK 9 - default.property does not define eecap-1.9
Date Mon, 02 Mar 2015 11:52:04 GMT

     [ https://issues.apache.org/jira/browse/FELIX-4808?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arindam Bandyopadhyay updated FELIX-4808:
-----------------------------------------
    Issue Type: Improvement  (was: Bug)

> JDK 9 - default.property does not define eecap-1.9
> --------------------------------------------------
>
>                 Key: FELIX-4808
>                 URL: https://issues.apache.org/jira/browse/FELIX-4808
>             Project: Felix
>          Issue Type: Improvement
>          Components: Main Distribution
>            Reporter: Arindam Bandyopadhyay
>            Priority: Critical
>
> default.property under felix.jar does not define eecap-1.9 . default.property file under
felix.jar should contain the following entry
> eecap-1.9= osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0,1.1,1.2",
\
>  osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7,1.8,1.9"
> This entry is needed to resolve the Require-Capability osgi.ee if we run using JDK 9.

> Glassfish uses Felix as a osgi container . I tried to run glassfish using JDK 9. However
glassfish could not start up as some of it's modules need to resolve  Require-Capability osgi.ee
.
> So if we need to run felix in JDK 9 we need to add  eecap-1.9 in default.property file.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message