felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-4550) Upgrade embedded Jetty to version 9.2.x in Felix Http Jetty
Date Fri, 16 Jan 2015 12:18:35 GMT

    [ https://issues.apache.org/jira/browse/FELIX-4550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14280154#comment-14280154
] 

Carsten Ziegeler commented on FELIX-4550:
-----------------------------------------

I've committed a fix which allows us to easily switch the target java version. all modules
except the jetty one require java 6 while jetty requires java 7
I also enabled baselining for some modules

I had to change the version ranges of some dependencies as in my case always a wrong version
was picked up. I'm not sure if we really should go with version ranges anyway.

> Upgrade embedded Jetty to version 9.2.x in Felix Http Jetty
> -----------------------------------------------------------
>
>                 Key: FELIX-4550
>                 URL: https://issues.apache.org/jira/browse/FELIX-4550
>             Project: Felix
>          Issue Type: New Feature
>          Components: HTTP Service
>            Reporter: Chetan Mehrotra
>            Assignee: J.W. Janssen
>         Attachments: 141204_FELIX-4550_jetty9.patch, FELIX-4550.patch
>
>
> Currently HTTP Service embeds Jetty 8.1.14.v20131031 which supports Servlet 3.0. Current
Jetty version 9.2.1.v20140609 supports Servlet 3.1 which provided access to some new NIO based
features. Further it also provides lots of new features like Spdy support , Websocket support
etc [1]
> [1] https://webtide.com/jetty-9-features/



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message