felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart McCulloch (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-4626) maven-bundle-plugin does not insert package range to Import-Package clause
Date Thu, 27 Nov 2014 10:14:12 GMT

    [ https://issues.apache.org/jira/browse/FELIX-4626?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14227467#comment-14227467
] 

Stuart McCulloch commented on FELIX-4626:
-----------------------------------------

I don't think it's that clear, since the same maven plugin code produces different results
depending whether it uses bndlib 2.2.0 or 2.4.0. The missing version is also not removed on
the maven side, it's been removed in the manifest returned by bnd. So it may be that we need
to call some different API (or make an extra call somewhere) with later versions of bndlib,
but it doesn't rule out a behaviour change in bnd in the code-path used by the plugin, but
not the code-path used by the command-line. The maven plugin also enables various extensions
(blueprint, scr) which are not enabled on the command-line, and this could also change the
code-path used in bnd.

Anyway, just pointing out this needs further investigation to find out exactly where the change
occurred and how to fix it.

> maven-bundle-plugin does not insert package range to Import-Package clause
> --------------------------------------------------------------------------
>
>                 Key: FELIX-4626
>                 URL: https://issues.apache.org/jira/browse/FELIX-4626
>             Project: Felix
>          Issue Type: Bug
>    Affects Versions: maven-bundle-plugin-2.5.0
>            Reporter: Balazs Zsoldos
>
> With maven-bundle-plugin 2.4.0 everything is ok:
> {code}
> Import-Package: org.everit.osgi.cache;version="[2.0,3)",org.osgi.framewo rk;version="[1.6,2)"
> {code}
> With version 2.5.0 the header is the following:
> {code}
> Import-Package: org.everit.osgi.cache,org.osgi.framework;version="1.6,2)"
> {code}
> The version range from org.everit.osgi.cache package is missing.
> __To reproduce:__
>  - Check out the repository https://github.com/everit-org/cache-noop
>  - Replace the version of maven-bundle-plugin from 2.4.0 to 2.5.0.
> The sample project and its dependency has 1-1 package.
> I created an issue for bndlib but I got the response that this might be a bug of maven-bundle-plugin.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message