felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ferry Huberts (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FELIX-4568) webconsole doesn't recognise pipe '|' as list separator
Date Thu, 06 Nov 2014 12:06:34 GMT

    [ https://issues.apache.org/jira/browse/FELIX-4568?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14200126#comment-14200126
] 

Ferry Huberts edited comment on FELIX-4568 at 11/6/14 12:06 PM:
----------------------------------------------------------------

Webconsole 4.2.2.all shows the correct thing (a list/array) now but only when I use the defaults.

When I use an override like
{noformat}
bandwidths=dev1=1\\,2,dev2=3\\,4 
{noformat}
then webconsole shows the literal string as a single element instead of two elements.

I use FileInstall for the config

I've debugged through the code and the code correctly sees a list of elements.


was (Author: mailings@hupie.com):
Webconsole 4.2.2.all shows the correct thing (a list/array) now but only when I use the defaults.

When I use an override like
{noformat}
bandwidths=dev1=1\\,2,dev2=3\\,4 
{noformat}
then webconsole shows the literal string as a single element instead of two elements.

I use FileInstall for the config

> webconsole doesn't recognise pipe '|' as list separator
> -------------------------------------------------------
>
>                 Key: FELIX-4568
>                 URL: https://issues.apache.org/jira/browse/FELIX-4568
>             Project: Felix
>          Issue Type: Bug
>          Components: Web Console
>    Affects Versions: webconsole-4.2.2
>         Environment: Linux x64
>            Reporter: Ferry Huberts
>         Attachments: Screenshot of the example.png
>
>
> with (bnd call)
>   Config config = Configurable.createConfigurable(Config.class, props);
> I create a Config object.
> In Config is a
>   List<String> entries();
> the default for this is 'a|b|c'
> bnd uses the pipe '|' character to split the Strings
> webconsole uses the comma ',' character to split
> which one is it doing the right thing? :-) 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message