felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (FELIX-4150) _verisonpolicy doesn't seem to work with maven-bundle-plugin-2.4.0
Date Tue, 17 Jun 2014 11:34:02 GMT

     [ https://issues.apache.org/jira/browse/FELIX-4150?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet closed FELIX-4150.
----------------------------------

    Resolution: Won't Fix

> _verisonpolicy doesn't seem to work with maven-bundle-plugin-2.4.0
> ------------------------------------------------------------------
>
>                 Key: FELIX-4150
>                 URL: https://issues.apache.org/jira/browse/FELIX-4150
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven Bundle Plugin
>    Affects Versions: maven-bundle-plugin-2.4.0
>         Environment: Windows 8
>            Reporter: Joshua
>
> We have been using maven-bundle-plugin-2.3.7 in our poms
> We specified the version policy in the configuration instructions for each plugin in
every pom like this...
> <_versionpolicy>${version;==;${@}}</_versionpolicy>
> With the 2.3.7 plugin this would result in the manifest having imports with a minimum
version like this...
> com.sun.jna;version="3.2"
> When I bumped the plugin to 2.4 my imports now are back to the default version policy.
> com.sun.jna;version="[3.2,4)"
> even though I still have _versionpolicy in the config.
> I looked at the release notes for 2.4 and didn't see anything about taking this functionality
out. 
> Should the version policy still work, or did I miss some documentation on how the plugin
has changed?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message