felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Gogo shell doesn't work with Java 8
Date Wed, 26 Mar 2014 12:53:29 GMT
On 3/26/14, 03:53 , Derek Baum wrote:
> no problem.
>
> I applied the fix locally last weekend, but the gogo tests were failing for some reason
I have not yet investigated:
>
> org/apache/felix/gogo/command/Inspect.java:280: error: incompatible types
> [ERROR] BundleWiring wiring = b.adapt(BundleWiring.class);

I think this is due to the fact that Gogo Command depends on 
org.osgi.core 4.3.0 which is compiled with target jsr14, which doesn't 
work when compiling with Java 7. So, either build with an older version 
of Java or else change the dependency to org.osgi.core 5.0.0...not sure 
which makes more sense.

-> richard

>
>
> —
> Derek
>
> On 25 Mar 2014, at 18:13, Nicolas Roduit <Nicolas.Roduit@jmicrovision.com> wrote:
>
>> Thanks to take into account this bug (https://issues.apache.org/jira/browse/FELIX-4425)
in the next release. A fix is proposed in JIRA.


Mime
View raw message