felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Meschberger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-3708) [DS] use java 5
Date Mon, 22 Oct 2012 06:24:12 GMT

    [ https://issues.apache.org/jira/browse/FELIX-3708?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13481199#comment-13481199

Felix Meschberger commented on FELIX-3708:

IIRC the 4.3 compendium jars have been compiled with the jsr14 source flag. This creates Java
1.4 class files in a manner to run on Java 1.4 through 6 but creating massive problems with
Java 7.

If we do release Java 5 builds, we might want to consider extracting the source from the compendium
jars and have them built during the scr build to ensure they use the same source flag (Java
5 or jsr14) as the rest of the scr code.
> [DS] use java 5
> ---------------
>                 Key: FELIX-3708
>                 URL: https://issues.apache.org/jira/browse/FELIX-3708
>             Project: Felix
>          Issue Type: Bug
>          Components: Declarative Services (SCR)
>    Affects Versions: scr-1.8.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: scr-1.8.0
> Switching to java 5 to make refactoring more plausible.  If there are objections we can
switch back later.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message