felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Chemouil (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-3621) Two dimensional array as argument to a method in a component
Date Wed, 19 Sep 2012 16:19:08 GMT

    [ https://issues.apache.org/jira/browse/FELIX-3621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13458798#comment-13458798
] 

Simon Chemouil commented on FELIX-3621:
---------------------------------------

I've fixed the bug and ran some tests (more extensive than the attached testcase) and it seems
to work.

As Clement said, it's a name mangling problem in the flag member of methods containing multi-dimensional
arrays (two or higher). My patch keeps the current mangling scheme of using underscores (_'s)
in place of array brackets, but since it now supports multi-dimensional arrays there can be
4, 6, 8, .. underscores in the flag name depending of the array's dimension.  Currently the
manipulator does not depend on Common Utils or a similar library that has nice String utils
so there's a ugly Stringbuilder concatenating underscores in the patch, but other than that
it's pretty straightforward. I am too lazy to include unit tests for this, but in the worst
case scenario it will work as bad as currently ;)

Maybe for inclusion in 1.9.0?
                
> Two dimensional array as argument to a method in a component
> ------------------------------------------------------------
>
>                 Key: FELIX-3621
>                 URL: https://issues.apache.org/jira/browse/FELIX-3621
>             Project: Felix
>          Issue Type: Bug
>          Components: iPOJO
>    Affects Versions: iPOJO-1.8.0
>         Environment: Ubuntu 11.04, Java Sun 1.6.0_26, Felix 4.1.0-SNAPSHOT, Maven iPOJO
Version 1.8.0
>            Reporter: Remi Druilhe
>            Assignee: Clement Escoffier
>         Attachments: felix3621.patch, test.zip
>
>
> I recently tried to pass a two dimensional array to a private method but when I start
my bundle into Felix, the factory of my component is created but not the instance. Note that
the compilation does not warn me.
> If I comment this code, there is no more problem. I tried using the maven-ipojo 1.8.0
and 1.9.0-SNAPSHOT, same problem.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message