felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clement Escoffier (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (FELIX-3621) Two dimensional array as argument to a method in a component
Date Sun, 09 Sep 2012 08:33:07 GMT

     [ https://issues.apache.org/jira/browse/FELIX-3621?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Clement Escoffier reassigned FELIX-3621:

    Assignee: Clement Escoffier
> Two dimensional array as argument to a method in a component
> ------------------------------------------------------------
>                 Key: FELIX-3621
>                 URL: https://issues.apache.org/jira/browse/FELIX-3621
>             Project: Felix
>          Issue Type: Bug
>          Components: iPOJO
>    Affects Versions: iPOJO-1.8.0
>         Environment: Ubuntu 11.04, Java Sun 1.6.0_26, Felix 4.1.0-SNAPSHOT, Maven iPOJO
Version 1.8.0
>            Reporter: Remi Druilhe
>            Assignee: Clement Escoffier
>         Attachments: test.zip
> I recently tried to pass a two dimensional array to a private method but when I start
my bundle into Felix, the factory of my component is created but not the instance. Note that
the compilation does not warn me.
> If I comment this code, there is no more problem. I tried using the maven-ipojo 1.8.0
and 1.9.0-SNAPSHOT, same problem.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message