felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (FELIX-3343) Installing an fragment bundle without Bundle-ManifestVersion: 2 causes NPE in resolver
Date Mon, 16 Apr 2012 18:52:19 GMT

     [ https://issues.apache.org/jira/browse/FELIX-3343?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard S. Hall resolved FELIX-3343.
------------------------------------

    Resolution: Fixed
      Assignee: Richard S. Hall

I believe I have committed a fix for this, please close if satisfied.
                
> Installing an fragment bundle without Bundle-ManifestVersion: 2 causes NPE in resolver
> --------------------------------------------------------------------------------------
>
>                 Key: FELIX-3343
>                 URL: https://issues.apache.org/jira/browse/FELIX-3343
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: framework-4.0.2
>            Reporter: Sahoo
>            Assignee: Richard S. Hall
>            Priority: Critical
>             Fix For: framework-4.2.0
>
>         Attachments: f1.jar
>
>
> You may call it a bad bundle (because fragment is a R4 concept as I understand), but
if someone forgets to set Bundle-ManifestVersion in a fragment, then Felix 4.0.2 won't start.
Just copy the attached f1.jar to bundle/ in a felix installation and start felix to see the
following exception:
> ERROR: Bundle org.apache.felix.gogo.shell [5] Error starting file:/space/ss141213/software/felix-framework-4.0.2/bundle/org.apache.felix.gogo.shell-0.10.0.jar
(java.lang.NullPointerException)
> java.lang.NullPointerException
> 	at org.apache.felix.framework.StatefulResolver$ResolverStateImpl.getCandidates(StatefulResolver.java:1263)
> 	at org.apache.felix.framework.resolver.Candidates.populateFragmentOndemand(Candidates.java:347)
> 	at org.apache.felix.framework.resolver.Candidates.populate(Candidates.java:148)
> 	at org.apache.felix.framework.resolver.ResolverImpl.resolve(ResolverImpl.java:115)
> 	at org.apache.felix.framework.StatefulResolver.resolve(StatefulResolver.java:168)
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3819)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
> 	at java.lang.Thread.run(Thread.java:619)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message