felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valentin Valchev (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FELIX-3473) web console config manager plugin no longer works with J9
Date Mon, 23 Apr 2012 13:13:33 GMT
Valentin Valchev created FELIX-3473:
---------------------------------------

             Summary: web console config manager plugin no longer works with J9
                 Key: FELIX-3473
                 URL: https://issues.apache.org/jira/browse/FELIX-3473
             Project: Felix
          Issue Type: Bug
          Components: Web Console
    Affects Versions: webconsole-3.4.0, webconsole-3.4.2
            Reporter: Valentin Valchev
            Assignee: Valentin Valchev
            Priority: Blocker


When started I've got the following exception:

Failed to instantiate plugin org.apache.felix.webconsole.internal.compendium.Con
figManager
java.lang.NoClassDefFoundError: java.util.regex.Pattern
at org.apache.felix.webconsole.internal.compendium.ConfigManager.<clinit
>(ConfigManager.java:98)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:206)
at java.lang.Class.newInstanceImpl(Native Method)
at java.lang.Class.newInstance(Class.java:1275)
at org.apache.felix.webconsole.internal.servlet.PluginHolder$InternalPlu
gin.doGetConsolePlugin(PluginHolder.java:748)
at org.apache.felix.webconsole.internal.servlet.PluginHolder$Plugin.getC
onsolePlugin(PluginHolder.java:535)
at org.apache.felix.webconsole.internal.servlet.PluginHolder.getPlugin(P
luginHolder.java:205)
at org.apache.felix.webconsole.internal.servlet.OsgiManager.initInternal
Plugins(OsgiManager.java:968)
at org.apache.felix.webconsole.internal.servlet.OsgiManager.updateConfig
uration(OsgiManager.java:933)
at org.apache.felix.webconsole.internal.servlet.OsgiManager.<init>(OsgiM
anager.java:318)
at org.apache.felix.webconsole.internal.OsgiManagerActivator.start(OsgiM
anagerActivator.java:42)
at com.prosyst.mbs.impl.framework.BundleImpl.startIt(BundleImpl.java:431
6)
at com.prosyst.mbs.impl.framework.BundleImpl.simpleStart(BundleImpl.java
:1750)
at com.prosyst.mbs.impl.framework.BundleImpl.start0(BundleImpl.java:1648
)
at com.prosyst.mbs.impl.framework.BundleImpl.start0(BundleImpl.java:1521
)
at com.prosyst.mbs.impl.framework.BundleImpl.start(BundleImpl.java:1356)

at com.prosyst.mbs.impl.framework.BundleImpl.start(BundleImpl.java:1066)

at com.prosyst.util.impl.parser.DefaultFrameworkPlugable.start(DefaultFr
ameworkPlugable.java:1296)


We should update the code to use case insensitive substring matching instead of regexp, which
is not available on older/embedded java JVMs.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message