felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clement Escoffier (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-3356) Objectweb ASM Clashes with IPojo
Date Tue, 21 Feb 2012 08:14:34 GMT

    [ https://issues.apache.org/jira/browse/FELIX-3356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13212443#comment-13212443
] 

Clement Escoffier commented on FELIX-3356:
------------------------------------------

iPOJO should keep ASM private. Because ven if we plan to switch to ASM 4.0, it does not fix
the issue with bundle requiring ASM 3.0 (APIs absolutely not compatible). So, iPOJO core,
composite and online manipulator should not export ASM packages.
                
> Objectweb ASM Clashes with IPojo
> --------------------------------
>
>                 Key: FELIX-3356
>                 URL: https://issues.apache.org/jira/browse/FELIX-3356
>             Project: Felix
>          Issue Type: Bug
>          Components: iPOJO
>    Affects Versions: iPOJO-1.8.0, ipojo-manipulator-1.8.2
>            Reporter: Bob Ziuchkovski
>            Assignee: Clement Escoffier
>            Priority: Minor
>             Fix For: ipojo-composite-1.8.2, ipojo-core-1.8.2, ipojo-manipulator-1.8.4
>
>
> Ipojo automatically imports org.apache.felix.ipojo.architecture for bundles that it manages,
and org.apache.felix.ipojo.architecture is marked as using org.objectweb.asm.  This creates
conflicts for any ipojo-managed bundle that wishes to import and use a different objectweb
asm version (i.e. 4.0) for non-ipojo purposes.  See the below output for an example:
> Error executing command: Error starting bundles:
> 	Unable to start bundle 107: Uses constraint violation. Unable to resolve bundle revision
test.service [107.0] because it is exposed to package 'org.objectweb.asm' from bundle revisions
org.objectweb.asm.all [98.0] and org.apache.felix.ipojo [99.0] via two dependency chains.
> Chain 1:
>   test.service [107.0]
>     import: (&(osgi.wiring.package=org.objectweb.asm)(version>=4.0.0)(!(version>=5.0.0)))
>      |
>     export: osgi.wiring.package=org.objectweb.asm
>   org.objectweb.asm.all [98.0]
> Chain 2:
>   test.service [107.0]
>     import: (&(osgi.wiring.package=org.apache.felix.ipojo.architecture)(version>=1.8.0))
>      |
>     export: osgi.wiring.package=org.apache.felix.ipojo.architecture; uses:=org.objectweb.asm
>     export: osgi.wiring.package=org.objectweb.asm
>   org.apache.felix.ipojo [99.0]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message