felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Gilmer <kgil...@gmail.com>
Subject Re: Using Animal Sniffer (was: [jira] [Resolved] (FELIX-3287) Light HTTP Service Java 1.3)
Date Tue, 10 Jan 2012 23:20:44 GMT
Hi Felix,

  That's a great idea, thanks!  I updated (revision 1229793) the root
httplite POM to include the Animal Sniffer plugin and it seems to be
working.  I cannot be certain, but maven downloads Animal Sniffer artifacts
and I get more build output.  I do not see a definitive "source valid"
message from the plugin but assume that since the build is successful that
the plugin didn't find any invalid source.

cheers
ken

On Wed, Jan 11, 2012 at 1:07 AM, Carsten Ziegeler <cziegeler@apache.org>wrote:

> +1
>
> Carsten
>
> 2012/1/9 Felix Meschberger <fmeschbe@adobe.com>:
> > Hi,
> >
> > We currently try to be strictly Java 1.3 by setting compiler source and
> target to 1.3 in the parent POM.
> >
> > How about adding the Codehaus Animal Sniffer plugin configured to ensure
> Java 1.3 API use ?
> >
> > (The WebConsole has the animal sniffer plugin configured for Java 1.4
> because we use regular expressions and some other Java 1.4 API)
> >
> > Regards
> > Felix
> >
> >
> > Am 08.01.2012 um 06:01 schrieb Ken Gilmer (Resolved) (JIRA):
> >
> >>
> >>     [
> https://issues.apache.org/jira/browse/FELIX-3287?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel]
> >>
> >> Ken Gilmer resolved FELIX-3287.
> >> -------------------------------
> >>
> >>    Resolution: Fixed
> >>
> >> All known non-Java-1.3-compatible code has been updated.
> >>
> >>> Light HTTP Service Java 1.3
> >>> ---------------------------
> >>>
> >>>                Key: FELIX-3287
> >>>                URL: https://issues.apache.org/jira/browse/FELIX-3287
> >>>            Project: Felix
> >>>         Issue Type: Improvement
> >>>         Components: Lightweight HTTP Service
> >>>           Reporter: Yann Diorcet
> >>>           Assignee: Ken Gilmer
> >>>        Attachments: patch1.patch
> >>>
> >>>
> >>> Almost all the code is compatible with Java 1.3 except
> ServletPrintWriter (Charset stuff).
> >>> Is it possible to make the code compatible with CDC
> (minimum/foundation)?
> >>
> >> --
> >> This message is automatically generated by JIRA.
> >> If you think it was sent incorrectly, please contact your JIRA
> administrators:
> https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> >> For more information on JIRA, see:
> http://www.atlassian.com/software/jira
> >>
> >>
> >
>
>
>
> --
> Carsten Ziegeler
> cziegeler@apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message