felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Gilmer <kgil...@gmail.com>
Subject Re: Release problem - need help
Date Thu, 19 Jan 2012 13:24:16 GMT
Hi Karl,

  Thanks for your ideas, that certainly helps!  Yes the SCM stuff is
incorrect for my 'complete' target and that is probably why it's hanging
up.

 Trying to follow your advice regarding the parent pom version...I am not
sure what you mean.  When I look at other projects that have the same
pattern (eventadmin), they use the same version.  I tried updating to
version 2 as is in the http project but received a maven error that that
version does not exist.  It seems like most of the subprojects that have
reactor/module builds use 1.0.4.  What am I missing?

 Regarding "... try to release the individual targets and not the
reactor.." how can I do this?  When I perform the release process in the
'minimum' directory (my first target) when I get to the 'mvn
release:perform' stage I can see in the console output that maven
propagates to the parent and other subproject poms, and tries to release
the other subproject's snapshot.  Finally it fails with the error below.
 How can I release just the minimum and complete targets?

Thanks!
ken

~~~
kgilmer@x220:~/dev/repos/felix-trunk/httplite/minimum$ mvn release:clean &&
mvn release:prepare
...<success>
kgilmer@x220:~/dev/repos/felix-trunk/httplite/minimum$ mvn release:perform
...
[INFO] [INFO] Installing
/home/kgilmer/dev/repos/felix-trunk/httplite/minimum/target/checkout/pom.xml
to
/home/kgilmer/.m2/repository/org/apache/felix/org.apache.felix.httplite.reactor/1-SNAPSHOT/org.apache.felix.httplite.reactor-1-SNAPSHOT.pom
[INFO] [INFO]
[INFO] [INFO] --- maven-deploy-plugin:2.4:deploy (default-deploy) @
org.apache.felix.httplite.reactor ---
[INFO] [INFO]
------------------------------------------------------------------------
[INFO] [INFO] Reactor Summary:
[INFO] [INFO]
[INFO] [INFO] Apache Felix Lightweight HTTP Service ............. SUCCESS
[20.910s]
[INFO] [INFO] Apache Felix Lightweight HTTP Service ............. SUCCESS
[19.977s]
[INFO] [INFO] Apache Felix Lightweight HTTP Service Reactor ..... FAILURE
[3.634s]
[INFO] [INFO]
------------------------------------------------------------------------
[INFO] [INFO] BUILD FAILURE
[INFO] [INFO]
------------------------------------------------------------------------
[INFO] [INFO] Total time: 45.258s
[INFO] [INFO] Finished at: Thu Jan 19 22:04:58 JST 2012
[INFO] [INFO] Final Memory: 34M/283M
[INFO] [INFO]
------------------------------------------------------------------------
[INFO] [ERROR] Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.4:deploy (default-deploy) on
project org.apache.felix.httplite.reactor: Failed to deploy
artifacts/metadata: No connector available to access repository
apache.snapshots (scp://
people.apache.org/www/people.apache.org/repo/m2-snapshot-repository) of
type default using the available factories WagonRepositoryConnectorFactory
-> [Help 1]



On Tue, Jan 17, 2012 at 6:23 AM, Karl Pauls <karlpauls@gmail.com> wrote:

> Your reactor pom is on a very old version of the felix parent pom.
> That is why you get the errors you see. However, we don't release the
> reactors but typically the indiviual targets.
>
> I think the reason they are going wrong is that your scm tag is not
> correct. It points in both cases (targets) to the root of your project
> (where the reactor is) but it should point to the subfolder of the
> actual target in that root ie.,
>
> <scm>
>                <connection>scm:svn:
> http://svn.apache.org/repos/asf/felix/trunk/httplite</connection>
>                <developerConnection>scm:svn:
> https://svn.apache.org/repos/asf/felix/trunk/httplite
> </developerConnection>
>                <url>http://svn.apache.org/repos/asf/felix/trunk/httplite
> </url>
> </scm>
>
> should become:
>
> <scm>
>                <connection>scm:svn:
> http://svn.apache.org/repos/asf/felix/trunk/httplite/complete</connection>
>                <developerConnection>scm:svn:
> https://svn.apache.org/repos/asf/felix/trunk/httplite/complete
> </developerConnection>
>                <url>
> http://svn.apache.org/repos/asf/felix/trunk/httplite/complete</url>
> </scm>
>
>
> Then try to release the individual targets and not the reactor. Does this
> help?
>
>
> regards,
>
> Karl
>
> On Wed, Jan 11, 2012 at 1:41 AM, Ken Gilmer <kgilmer@gmail.com> wrote:
> > Hi guys,
> >
> >  I'm still unable to follow the Felix release process without error.  I
> > did find one issue with my POMs not having the proper level of nesting
> when
> > referring to the parent POM.  I fixed this to match what's currently in
> the
> > eventadmin sub project.  I have tried doing the release process both on
> > each target and on the parent (reactor) pom.  Both produce errors.
> >
> > When trying to release per target (not reactor /httplite/minimum), I get
> to
> > the 'mvn deploy' stage.  After some uploading, I get to:
> > [INFO] [INFO] Retrieving previous build number from apache.snapshots
> > [INFO]
> > Maven never returns from this.  I can see in some of the build output
> that
> > maven is building and deploying my other target (httplite.complete) as
> > well, so I'm thinking that releasing at the target level may be
> incorrect.
> >
> > When trying to release the whole subproject (/httplite) I get to the 'mvn
> > deploy' stage.  I am prompted for my password after "[INFO] Retrieving
> > previous build number from apache.snapshots".  After this I see:
> >
> > Uploading: scp://
> >
> people.apache.org/www/people.apache.org/repo/m2-snapshot-repository/org/apache/felix/org.apache.felix.httplite.reactor/1-SNAPSHOT/org.apache.felix.httplite.reactor-1-20120111.002634-1.pom
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD ERROR
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Error deploying artifact: Exit code: 1 - mkdir: /www/
> >
> people.apache.org/repo/m2-snapshot-repository/org/apache/felix/org.apache.felix.httplite.reactor
> :
> > Permission denied
> >
> > Logging into people.apache.org, in /www/
> > people.apache.org/repo/m2-snapshot-repository/org/apache/felix/ I can
> see
> > there is only one directory from 2009 so I suspect that maven is doing
> the
> > wrong thing and I should not be releasing from the root level.
> >
> > At this point I'm not sure how to proceed with the release.  Any
> > suggestions or ideas on how to perform a release with multiple modules
> > (like http, eventadmin, deployadmin, etc.) would be greatly appreciated.
> >
> > thx
> > ken
>
>
>
> --
> Karl Pauls
> karlpauls@gmail.com
> http://twitter.com/karlpauls
> http://www.linkedin.com/in/karlpauls
> https://profiles.google.com/karlpauls
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message