felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjun Panday <arjun.pan...@alcatel-lucent.com>
Subject Re: mvn release:prepare "Unable to tag SCM"
Date Mon, 16 Jan 2012 19:39:28 GMT
Thanks David,

Finally it worked :)

I tried to follow your advice but then maven was looking for a released 
version of the parent pom.
The problem was that I was trying to release core only, without the 
sample module.
I finally put everything back to where it was and simply commented out 
the sample module, then released from the parent level.

.. seems obvious once it works!

On 01/13/2012 10:15 PM, David Jencks wrote:
> On Jan 13, 2012, at 12:32 PM, Arjun Panday wrote:
>> Thanks David,
>>> Maybe the svn path in the pom is wrong?  the working directory appears to indicate
a different path including "/core/"
>> Yes, i showed this line on purpose.
>> the working directory is webconsole-plugins/servicediagnostics/core
>> and the artifactId is org.apache.felix.servicediagnostics.plugin
>> It seems to mix artifactId and the directory
>> The parent pom references the module as "core". Here's the scm and modules extract
from the parent pom:
>> <scm>
>> <connection>scm:svn:http://svn.apache.org/repos/asf/felix/trunk/webconsole-plugins/servicediagnostics</connection>
>> <developerConnection>scm:svn:https://svn.apache.org/repos/asf/felix/trunk/webconsole-plugins/servicediagnostics</developerConnection>
>> <url>http://svn.apache.org/viewvc/felix/trunk/webconsole-plugins/servicediagnostics</url>
>> </scm>
>> <modules>
>> <module>core</module>
>> <module>sample</module>
>> </modules>
>> Is this wrong?
> Are you running the release from "core" or "servicediagnostics"?  I think you can only
reliably run a release at the level of a pom that includes scm information.  If you just want
to release core I'd try putting scm info in that pom too.
> david jencks
>>> what's giving the warning?  tar?  There might be an issue with antique non-gnu
tars and long paths, I think there might be a flag to use gnu style tar.
>> Yes it comes from tar:
>> [INFO] [WARNING] Resulting tar file can only be processed successfully by GNU compatible
tar commands

View raw message