felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjun Panday <arjun.pan...@alcatel-lucent.com>
Subject Re: Error deploying artifact: Failed to transfer file
Date Wed, 04 Jan 2012 10:39:27 GMT
Hi Ken,

No, I've tried again just now and keep getting the 401 error.
I don't know if others are still facing the same issue.
If it works for you let me know!

Thanks,
Arjun


On 01/04/2012 02:48 AM, Ken Gilmer wrote:
> Sorry I can't provide any help in fixing this but am wondering...is it
> working now?  I'm planning on a httplite release shortly.
>
> thx!
> ken
>
> On Fri, Dec 30, 2011 at 4:51 PM, Arjun Panday
> <arjun.panday@alcatel-lucent.com>  wrote:
>> Thanks Carsten,
>>
>> I guess I should not proceed with the release without this step, so I'll
>> just try again later.
>>
>> Regards,
>> Arjun
>>
>>
>> On 12/30/2011 07:36 AM, Carsten Ziegeler wrote:
>>> Hi,
>>>
>>> I see the same error when the Apache Jenkins instance tries to deploy
>>> snapshots of Sling, so I fear it's rather a problem with the snapshot
>>> repository than with your settings.
>>>
>>> Regards
>>> Carsten
>>>
>>> 2011/12/30 Arjun Panday<arjun.panday@alcatel-lucent.com>:
>>>> Hi everyone,
>>>>
>>>> It's my turn to go through the ring of fire and attempt a release :)
>>>>
>>>> "mvn release:prepare -DdryRun=true" was successful and i'm now trying to
>>>> publish a snapshot, but I get the infamous 401 HTTP error:
>>>>
>>>> [INFO] Error deploying artifact: Failed to transfer file:
>>>>
>>>> https://repository.apache.org/content/repositories/snapshots/org/apache/felix/servicediagnostics/0.1.0-SNAPSHOT/servicediagnostics-0.1.0-20111229.225958-1.pom.
>>>> Return code is: 401
>>>>
>>>> I know it's supposed to be something with my settings.xml but I can't
>>>> figure
>>>> out what. Below is my settings.xml with the apache servers, username and
>>>> password (removed!). Am I missing a server entry? Can someone help me
>>>> figure
>>>> out what I did wrong?
>>>>
>>>> I also checked my pom's parent:
>>>> <parent>
>>>> <groupId>org.apache.felix</groupId>
>>>> <artifactId>felix-parent</artifactId>
>>>> <version>2.1</version>    <!-- should this be 3-SNAPSHOT ?
-->
>>>> <relativePath>../../pom/pom.xml</relativePath>
>>>> </parent>
>>>>
>>>> Thanks,
>>>> Arjun
>>>>
>>>> <settings>
>>>> <servers>
>>>> <!-- To publish a snapshot of some part of Maven -->
>>>> <server>
>>>> <id>apache.snapshots.https</id>
>>>> <username>apanday</username>
>>>> <password>{encrypted password}</password>
>>>> </server>
>>>> <!-- To publish a website of some part of Maven -->
>>>> <server>
>>>> <id>apache.website</id>
>>>> <username>apanday</username>
>>>> <filePermissions>664</filePermissions>
>>>> <directoryPermissions>775</directoryPermissions>
>>>> </server>
>>>> <!-- To stage a release of some part of Maven -->
>>>> <server>
>>>> <id>apache.releases.https</id>
>>>> <username>apanday</username>
>>>> <password>{encrypted password}</password>
>>>> </server>
>>>> <!-- To stage a website of some part of Maven -->
>>>> <server>
>>>> <id>stagingSite</id>    <!-- must match hard-coded repository
identifier in
>>>> site:stage-deploy -->
>>>> <username>apanday</username>
>>>> <filePermissions>664</filePermissions>
>>>> <directoryPermissions>775</directoryPermissions>
>>>> </server>
>>>> </servers>
>>>> <profiles>
>>>> <profile>
>>>> <id>release</id>
>>>> <properties>
>>>> <gpg.passphrase>{encrypted password}</gpg.passphrase>
>>>> </properties>
>>>> </profile>
>>>> </profiles>
>>>> </settings>
>>>>
>>>


Mime
View raw message