felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ge@@ru" <gea...@gmail.com>
Subject Issue on maven-bundle-plugin on export osgi service with property on blueprint
Date Fri, 25 Nov 2011 14:35:34 GMT
Hi,

i don't know if this is an issue or is correct.

When it is create an osgi bundle with blueprint and service use property
like this example: 

<blueprint
    xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"

xmlns:cm="http://aries.apache.org/blueprint/xmlns/blueprint-cm/v1.0.0"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

xmlns:ext="http://aries.apache.org/blueprint/xmlns/blueprint-ext/v1.2.0"
default-availability="optional">
    <!--
    xsi:schemaLocation="
      http://www.osgi.org/xmlns/blueprint/v1.0.0
      http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd">
      -->

      <service ref="helloservice"
interface="it.test.helloword.HelloWord" >
        <service-properties>
          <entry key="version">
            <value type="java.lang.String">2</value>
          </entry>
        </service-properties>
      </service>

      <bean id="helloservice" class="it.test.HelloWordImpl"
init-method="startUp">
      </bean>
</blueprint>

On manifest property value isn't visible:

Export-Service: it.test.helloword.HelloWord;version=""

Is correct that value isn' present ? 

However, service and use of the properties are correct, all works fine.

Thanks in advance.

Geaaru



Mime
View raw message