felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-3115) Bundle-RequiredExecutionEnvironment matching fails when multiple environment is specified in org.osgi.framework.executionenvironment
Date Tue, 20 Sep 2011 18:21:09 GMT

    [ https://issues.apache.org/jira/browse/FELIX-3115?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13108896#comment-13108896
] 

Richard S. Hall commented on FELIX-3115:
----------------------------------------

This appears to be working in OBR 1.6.6...at least it did for me.

> Bundle-RequiredExecutionEnvironment matching fails when multiple environment is specified
in org.osgi.framework.executionenvironment
> ------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: FELIX-3115
>                 URL: https://issues.apache.org/jira/browse/FELIX-3115
>             Project: Felix
>          Issue Type: Bug
>          Components: Bundle Repository (OBR)
>    Affects Versions: bundlerepository-1.6.2
>            Reporter: Sahoo
>             Fix For: bundlerepository-1.6.8
>
>
> OBR failed to a bundle which has Bundle-RequiredExecutionEnvironment as J2SE-1.5 in an
environment where 
> org.osgi.framework.executionenvironment=JavaSE-1.6,J2SE-1.5,J2SE1.4,J2SE-1.3,J2SE-1.2
> This seems to be a bug in FilterImpl.matchCase() method which is failing to match a requirement
like:
> ee:(|(ee=J2SE-1.5))
> with a capability like:
> ee:{ee=JavaSE-1.6,J2SE-1.5,J2SE1.4,J2SE-1.3,J2SE-1.2}
> If I set org.osgi.framework.executionenvironment=J2SE-1.5, the bundle deploys fine.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message