felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FELIX-3015) [Framework] Provide org.osgi.util.tracker version 1.5
Date Wed, 31 Aug 2011 17:36:09 GMT

     [ https://issues.apache.org/jira/browse/FELIX-3015?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard S. Hall updated FELIX-3015:
-----------------------------------

    Summary: [Framework] Provide org.osgi.util.tracker version 1.5  (was: Manifest provides
tracker 1.5 but runtime sees 1.4)

> [Framework] Provide org.osgi.util.tracker version 1.5
> -----------------------------------------------------
>
>                 Key: FELIX-3015
>                 URL: https://issues.apache.org/jira/browse/FELIX-3015
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>            Reporter: Pascal Rapicault
>             Fix For: framework-4.0.0
>
>         Attachments: TestTRacker_1.0.0.201106280449.jar, felix.jar
>
>
> Code from trunk.
> I must be missing something but when I run the attached jar of the framework which export
org.osgi.util.tracker 1.5 and try to import the tracker package 1.5 from another bundle it
fails. Doing a headers command shows that the fwk exports version 1.4... I'm confused :)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message