felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FELIX-3083) maven-bundle-plugin 2.3.5 breaks compatibility with Java5
Date Wed, 24 Aug 2011 15:50:29 GMT
maven-bundle-plugin 2.3.5 breaks compatibility with Java5

                 Key: FELIX-3083
                 URL: https://issues.apache.org/jira/browse/FELIX-3083
             Project: Felix
          Issue Type: Bug
          Components: Maven Bundle Plugin
    Affects Versions: webconsole-3.1.8
            Reporter: Daniel Kulp

Using maven-bundle-plugin version 2.3.4 works fine, but with with 2.3.5 and Java 5, we get
a stack trace of:
 Caused by: java.lang.NoSuchMethodError: java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B
        at aQute.lib.osgi.Jar.<clinit>(Jar.java:290)
        at org.apache.felix.bundleplugin.BundlePlugin.getClasspath(BundlePlugin.java:942)
        at org.apache.felix.bundleplugin.BundlePlugin.execute(BundlePlugin.java:261)
        at org.apache.felix.bundleplugin.BundlePlugin.execute(BundlePlugin.java:252)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
        ... 11 more

I guess that's technically a bug in the aQute.lib stuff, but I'm logging here as maven users
will likely encounter it.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message