felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pascal Rapicault (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FELIX-3015) Manifest provides tracker 1.5 but runtime sees 1.4
Date Tue, 28 Jun 2011 03:08:19 GMT

     [ https://issues.apache.org/jira/browse/FELIX-3015?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pascal Rapicault updated FELIX-3015:
------------------------------------

    Attachment: TestTRacker_1.0.0.201106280449.jar
                felix.jar

Attaching fwk jar built locally from trunk and a test bundle.

> Manifest provides tracker 1.5 but runtime sees 1.4
> --------------------------------------------------
>
>                 Key: FELIX-3015
>                 URL: https://issues.apache.org/jira/browse/FELIX-3015
>             Project: Felix
>          Issue Type: Bug
>            Reporter: Pascal Rapicault
>         Attachments: TestTRacker_1.0.0.201106280449.jar, felix.jar
>
>
> Code from trunk.
> I must be missing something but when I run the attached jar of the framework which export
org.osgi.util.tracker 1.5 and try to import the tracker package 1.5 from another bundle it
fails. Doing a headers command shows that the fwk exports version 1.4... I'm confused :)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message