felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-3015) Manifest provides tracker 1.5 but runtime sees 1.4
Date Tue, 28 Jun 2011 17:56:17 GMT

    [ https://issues.apache.org/jira/browse/FELIX-3015?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13056677#comment-13056677
] 

Richard S. Hall commented on FELIX-3015:
----------------------------------------

Yeah, there is something a little fishy here. It does appear that Service Tracker 1.5 is included
in framework trunk, even though it hasn't been released yet (neither has framework trunk,
for that matter). I guess we need to decide if we will keep this in there or not, but I can
defer that decision until we go to release framework trunk, which won't happen until framework
4.0.

In the meantime, I'll update the framework properties to export 1.5. FYI, one reason you are
confused, is that you expect the manifest file to be the rule that defines what the system
bundle exports, but it is not for the Felix framework. The framework's OSGi manifest headers
are present purely because we use bnd to create the it, not because they serve any purpose.
All of that is controlled by configuration properties and the default properties are in the
default.properties file embedded in the framework.jar file. In this file, it still says the
framework is exporting 1.4...I change that now to be 1.5.

However, I'll leave this bug open and assign its fix version so I can remember to deal with
this one way or the other before releasing framework 4.0. Thanks.

> Manifest provides tracker 1.5 but runtime sees 1.4
> --------------------------------------------------
>
>                 Key: FELIX-3015
>                 URL: https://issues.apache.org/jira/browse/FELIX-3015
>             Project: Felix
>          Issue Type: Bug
>            Reporter: Pascal Rapicault
>         Attachments: TestTRacker_1.0.0.201106280449.jar, felix.jar
>
>
> Code from trunk.
> I must be missing something but when I run the attached jar of the framework which export
org.osgi.util.tracker 1.5 and try to import the tracker package 1.5 from another bundle it
fails. Doing a headers command shows that the fwk exports version 1.4... I'm confused :)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message