felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (FELIX-2917) Constructor of SecurityExceptino() which is incompatible to 1.4 is used
Date Mon, 18 Apr 2011 14:08:05 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2917?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard S. Hall reopened FELIX-2917:
------------------------------------


> Constructor of SecurityExceptino() which is incompatible to 1.4 is used  
> -------------------------------------------------------------------------
>
>                 Key: FELIX-2917
>                 URL: https://issues.apache.org/jira/browse/FELIX-2917
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: framework-3.2.0
>         Environment: J2SE-1.4
>            Reporter: Ikuo YAMASAKI
>            Assignee: Richard S. Hall
>             Fix For: framework-3.2.1
>
>
> The constructor of SecurityException with Throwable must not be used.
> For example, Felix.java has 
> --------
> throw new SecurityException(ex);
> throw new SecurityException("Unable to install custom SecurityManager: " + security,
t);
> --------
> Other classes might use those constructors.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message