felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] Created: (FELIX-2732) [iPOJO] Service modified callback should define a default method name
Date Thu, 16 Dec 2010 15:37:02 GMT
[iPOJO] Service modified callback should define a default method name
---------------------------------------------------------------------

                 Key: FELIX-2732
                 URL: https://issues.apache.org/jira/browse/FELIX-2732
             Project: Felix
          Issue Type: Improvement
          Components: iPOJO
    Affects Versions: iPOJO-1.6.0
            Reporter: Richard S. Hall
            Priority: Minor


iPOJO supports service modified events via a callback. Logically, this is related to bind/unbind
methods. For bind/unbind methods, iPOJO uses a default naming scheme to detect bind/unbind
pairs. For the modified callback, it doesn't, which means you are forced to use an ID in this
case. It would be nice if iPOJO supported a default name for this too (e.g., bindFoo()/unbindFoo()/modifiedFoo()).

On a related note, I don't see this feature documented (at least not the @Modified annotation).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message