felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clement Escoffier (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-2732) [iPOJO] Service modified callback should define a default method name
Date Fri, 17 Dec 2010 15:27:00 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2732?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Clement Escoffier resolved FELIX-2732.
--------------------------------------

       Resolution: Fixed
    Fix Version/s: iPOJO-1.8.0

Fixed in trunk

> [iPOJO] Service modified callback should define a default method name
> ---------------------------------------------------------------------
>
>                 Key: FELIX-2732
>                 URL: https://issues.apache.org/jira/browse/FELIX-2732
>             Project: Felix
>          Issue Type: Improvement
>          Components: iPOJO
>    Affects Versions: iPOJO-1.6.0
>            Reporter: Richard S. Hall
>            Assignee: Clement Escoffier
>            Priority: Minor
>             Fix For: iPOJO-1.8.0
>
>
> iPOJO supports service modified events via a callback. Logically, this is related to
bind/unbind methods. For bind/unbind methods, iPOJO uses a default naming scheme to detect
bind/unbind pairs. For the modified callback, it doesn't, which means you are forced to use
an ID in this case. It would be nice if iPOJO supported a default name for this too (e.g.,
bindFoo()/unbindFoo()/modifiedFoo()).
> On a related note, I don't see this feature documented (at least not the @Modified annotation).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message