felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glyn Normington (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-2466) Failure to resolve gemini-web bundles
Date Fri, 09 Jul 2010 08:41:49 GMT

    [ https://issues.apache.org/jira/browse/FELIX-2466?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12886651#action_12886651
] 

Glyn Normington commented on FELIX-2466:
----------------------------------------

This is a problem with a bundle in the Enterprise Bundle Repository. Please file a bug against
the EBR. See http://www.springsource.com/repository/app/faq#q10 for how to do this.

> Failure to resolve gemini-web bundles
> -------------------------------------
>
>                 Key: FELIX-2466
>                 URL: https://issues.apache.org/jira/browse/FELIX-2466
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: framework-3.0.1
>         Environment: Gemini Web (1.1.0.M01)
>            Reporter: David Savage
>             Fix For: framework-3.2.0
>
>
> The gemini web bundles available from:
> http://www.eclipse.org/gemini/web/download/
> Fail to resolve in felix:
> 19  INSTALLED  com.springsource.org.apache.catalina.ha.springsource:6.0.20.S2-r5956
> 20  INSTALLED  com.springsource.org.apache.catalina.springsource:6.0.20.S2-r5956
> 21  INSTALLED  com.springsource.org.apache.catalina.tribes.springsource:6.0.20.S2-r5956
> 23  INSTALLED  com.springsource.org.apache.coyote.springsource:6.0.20.S2-r5956
> 26  INSTALLED  com.springsource.org.apache.jasper.springsource:6.0.20.S2-r5956
> 32  INSTALLED  org.eclipse.gemini.web.core:1.1.0.M01
> 33  INSTALLED  org.eclipse.gemini.web.extender:1.1.0.M01
> 34  INSTALLED  org.eclipse.gemini.web.tomcat:1.1.0.M01
> g! start 19
> org.osgi.framework.BundleException: Unresolved constraint in bundle com.springsource.org.apache.catalina.ha.springsource
[19]: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.apache.catalina)(version>=6.0.20.S2-r5956)(version<=6.0.20.S2-r5956))
- [19.0] package; (&(package=org.apache.catalina)(version>=6.0.20.S2-r5956)(version<=6.0.20.S2-r5956))
> The same set of bundles resolve ok in equinox.
> Guessing it might have something to do with fragments as they're definitely in use.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message