felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ulf Dittmer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-2462) Preferences Service does not work in the presence of the Security Service
Date Sun, 11 Jul 2010 10:36:49 GMT

    [ https://issues.apache.org/jira/browse/FELIX-2462?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12887175#action_12887175

Ulf Dittmer commented on FELIX-2462:

I'm assigning it AllPermission (as I do for all "trusted" bundles).

But the problem turned out to be that LogService (which is a dependency) wasn't installed
before PreferencesService; so I guess that the actual bug is that the error message is misleading.

> Preferences Service does not work in the presence of the Security Service
> -------------------------------------------------------------------------
>                 Key: FELIX-2462
>                 URL: https://issues.apache.org/jira/browse/FELIX-2462
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework Security, Preferences Service
>    Affects Versions: framework.security-1.2.0, prefs-1.0.4
>         Environment: Java 5 on OS X 10.5, but that's most likely irrelevant
>            Reporter: Ulf Dittmer
> Trying to install the Prefs 1.0.4 bundle into a Felix container in which Security 1.2.0
is installed results in this stack trace:
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.prefs
[2]: Unable to resolve 2.0: missing requirement [2.0] package; (package=org.apache.felix.prefs)
- [2.0] package; (package=org.apache.felix.prefs)
>      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3421)
>      at org.apache.felix.framework.Felix.startBundle(Felix.java:1754)
>      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
>      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
> Using Prefs 1.0.4 without the security framework works fine; Felix version is 3.0.1.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message