felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (FELIX-2310) Karaf framework environment is not set correctly
Date Thu, 03 Jun 2010 16:34:56 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2310?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jarek Gawor reopened FELIX-2310:
--------------------------------


The org.osgi.framework.executionenvironment property needs to list all supported execution
environments. Otherwise, bundles with for example Bundle-RequireExecutionEnvironment: J2SE-3.0
will fail to resolve on Karaf. Try for example to install and start http://repo2.maven.org/maven2/asm/asm-all/3.2/asm-all-3.2.jar.
The bundle will fail to start with:  Unresolved constraint in bundle org.objectweb.asm.all
[35]: Execution environment not supported: J2SE-1.3.

This problem also affects OBR-based resolution - but OBR also has another problem that's related
to execution environments (see  FELIX-2385).





> Karaf framework environment is not set correctly
> ------------------------------------------------
>
>                 Key: FELIX-2310
>                 URL: https://issues.apache.org/jira/browse/FELIX-2310
>             Project: Felix
>          Issue Type: Bug
>          Components: Karaf
>            Reporter: Guillaume Nodet
>            Assignee: Guillaume Nodet
>             Fix For: karaf 1.6.0
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message