felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Lenzi <le...@apache.org>
Subject Re: Error with UPnP Base driver
Date Tue, 01 Jun 2010 12:54:41 GMT
On 01/06/2010 1.58, charbel el_kaed wrote:
> Hi Stefano, 
> Thanks for your reply.
> I can't actually touch those bundles. Is there another way to do so ?

Have you checked if the hypothesis regarding the import/export headers
of bundle 20 and 22 are correct? If they aren't then the source of the
problem is somewhere else.

If the hypothesis are correct then you can change the import-package
header of the "UPnP Base Driver" in order to force the loading of the
classes from the bundle 0 by means of the bundle-symbolic-name parameter
of import-package header (see OSGi Service Platform Release 4 Version
4.2 page 52).

> Kind Regards,
> Charbel.

View raw message