felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-995) JRE packages are exported with wrong version
Date Fri, 07 May 2010 18:16:47 GMT

     [ https://issues.apache.org/jira/browse/FELIX-995?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Richard S. Hall resolved FELIX-995.
-----------------------------------

    Resolution: Fixed

Ok, as crazy as it is, I've modified the JRE package version numbering scheme to enable proper
sort order of versions so you can technically use them for version ranges and backwards compatibility.
The new scheme is like this:

    1_006_JavaSE

I put the version first and add some zeroes. I didn't use any zeroes in the major number because
I assume we won't live that long.

> JRE packages are exported with wrong version
> --------------------------------------------
>
>                 Key: FELIX-995
>                 URL: https://issues.apache.org/jira/browse/FELIX-995
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: framework-1.4.1
>         Environment: generic
>            Reporter: Sahoo
>            Assignee: Richard S. Hall
>             Fix For: framework-3.0.0
>
>
> Felix 1.4.1 exports JRE packages with a version equals to the JRE version. e.g., if I
am using Java SE 6, then all packages are exported with version=1.6. This is incorrect. Most
of the packages are versioned as per the JSRs they are defined by.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message