felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Guy Speton (JIRA)" <j...@apache.org>
Subject [jira] Closed: (FELIX-2265) bundle-version of Fragment-Host is resolving outside of specified range
Date Mon, 12 Apr 2010 18:21:50 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2265?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Guy Speton closed FELIX-2265.
----------------------------------

    Resolution: Invalid

You are correct, this was a red herring, the problem was elsewhere.  Sorry for the trouble.

> bundle-version of Fragment-Host is resolving outside of specified range
> -----------------------------------------------------------------------
>
>                 Key: FELIX-2265
>                 URL: https://issues.apache.org/jira/browse/FELIX-2265
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: felix-2.0.4
>         Environment: Java 5, MacOSX 10.5.8, felix 2.0.4
>            Reporter: Jean-Guy Speton
>
> In my application the following bundle host:
> Bundle-SymbolicName: com.mypackage 
> Bundle-Version: 1.6.1 
> is resolving this fragment:
> Bundle-SymbolicName: com.mypackage.frag 
> Bundle-Version: 1.6.2 
> Fragment-Host: com.mypackage; bundle-version="1.6.2" 
> Expectation is that the fragment would resolve to only versions 1.6.2 or higher of the
host bundle.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message