felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Pauls (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-995) JRE packages are exported with wrong version
Date Fri, 09 Apr 2010 13:41:50 GMT

    [ https://issues.apache.org/jira/browse/FELIX-995?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12855388#action_12855388
] 

Karl Pauls commented on FELIX-995:
----------------------------------

I think the 0.0.0.jre-1.6 idea makes sense. Maybe we should make it the name of the matching
execution-env for the qualifier (i.e., JRE-1.1, J2SE-1.2, J2SE-1.3, J2SE-1.4, J2SE-1.5, JavaSE-1.6)?

regards,

Karl

> JRE packages are exported with wrong version
> --------------------------------------------
>
>                 Key: FELIX-995
>                 URL: https://issues.apache.org/jira/browse/FELIX-995
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: felix-1.4.1
>         Environment: generic
>            Reporter: Sahoo
>             Fix For: felix-3.0.0
>
>
> Felix 1.4.1 exports JRE packages with a version equals to the JRE version. e.g., if I
am using Java SE 6, then all packages are exported with version=1.6. This is incorrect. Most
of the packages are versioned as per the JSRs they are defined by.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message