felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-2298) Component annotation: getConfigurationFactory should be named configurationFactory
Date Thu, 22 Apr 2010 10:33:49 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2298?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Carsten Ziegeler resolved FELIX-2298.
-------------------------------------

    Resolution: Fixed

Added new attribute in 936755

> Component annotation: getConfigurationFactory should be named configurationFactory
> ----------------------------------------------------------------------------------
>
>                 Key: FELIX-2298
>                 URL: https://issues.apache.org/jira/browse/FELIX-2298
>             Project: Felix
>          Issue Type: Bug
>          Components: Maven SCR Plugin, SCR Annotations
>    Affects Versions: maven-scr-plugin-1.4.2, scr annotations 1.2.0
>            Reporter: Carsten Ziegeler
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>             Fix For:  maven-scr-plugin-1.4.4,  scr annotations 1.2.2
>
>
> The getConfigurationFactory has been wrongly named at the component annotation, it should
rather be named configurationFactory
> We should deprecate the old one and add a new one.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message