felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Graham Charters (JIRA)" <j...@apache.org>
Subject [jira] Created: (FELIX-2173) Fix inconsistent maven->osgi version conversion between maven-bundle-plugin and DefaultMaven2OsgiConverter
Date Fri, 05 Mar 2010 14:12:27 GMT
Fix inconsistent maven->osgi version conversion between maven-bundle-plugin and DefaultMaven2OsgiConverter
----------------------------------------------------------------------------------------------------------

                 Key: FELIX-2173
                 URL: https://issues.apache.org/jira/browse/FELIX-2173
             Project: Felix
          Issue Type: Bug
          Components: Maven Bundle Plugin
            Reporter: Graham Charters


The maven bundle plug converts maven version like : 1.0.0-incubating-SNAPSHOT to 1.0.0.incubating-SNAPSHOT
which I think is correct.
The DefaultMaven2OsgiConverter coverts maven version like: 1.0.0-incubating-SNAPSHOT to 1.0.0.incubating_SNAPSHOT
which unnecessarily coverts '-' to '_'.
The conversion should be reusable and consistent to ensure they match when used in other plugins
or environments.  I think the DefaultMaven2OsgiConverter  needs to be changed to match the
maven bundle plugin.

See also: http://www.mail-archive.com/dev@felix.apache.org/msg15894.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message