felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Charters <gchart...@googlemail.com>
Subject Re: Maven bundle plugin version conversion
Date Thu, 04 Mar 2010 17:06:31 GMT
This bug seems to describe my poblem:

What I don't understand is why DefaultMaven2OsgiConverter gives
results different from the maven-bundle-plugin.

Any help in understanding this and how to resolve it would be greatly

Thanks, Graham.

On 4 March 2010 15:56, Graham Charters <gcharters@googlemail.com> wrote:
> Hi, I'm writing a maven plugin that needs to do coversion of maven
> versions to osgi versions.  I want to depend on the
> maven-bundle-plugin for this because I need the conversion scheme to
> be identical.  I've done this and started using the
> DefaultMaven2OsgiConverter, but for some reason, the versions I get
> are different from those generated by the maven-bundle-plugin.  For
> example, the converter changes 1.0.0-incubating-SNAPSHOT to
> 1.0.0.incubating_SNAPSHOT (as well as making it a valid OSGi version,
> it converts the '-' to '_'), whereas the maven-bundle-plugin changes
> this to 1.0.0.incubating-SNAPSHOT (leaves '-' alone).  Am I using the
> wrong bit of code to do the conversion or driving it incorrectly?  Any
> help would be greatly appreciated.
> My apologies if this should be on the users list rather than dev.  It
> seems to fall between the two...
> Many thanks,
> Graham.

View raw message