felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Meschberger (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-2179) junit does not need to be a compile scope dependency of configadmin
Date Sat, 06 Mar 2010 18:05:27 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2179?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Felix Meschberger resolved FELIX-2179.
--------------------------------------

       Resolution: Fixed
    Fix Version/s:     (was: felix-3.0.0)
                    configadmin-1.2.6

Thanks for reporting.

I have applied your patch in Rev. 919807

Actually none of the dependencies need to be compile. So changing dependencies to provided
and upgrading bundle plugin to be able to include classes from the provded dependency. Fixed
in Rev. 919808

> junit does not need to be a compile scope dependency of configadmin
> -------------------------------------------------------------------
>
>                 Key: FELIX-2179
>                 URL: https://issues.apache.org/jira/browse/FELIX-2179
>             Project: Felix
>          Issue Type: Bug
>          Components: Configuration Admin
>    Affects Versions:  configadmin-1.2.4
>            Reporter: David Jencks
>            Assignee: Felix Meschberger
>             Fix For:  configadmin-1.2.6
>
>         Attachments: FELIX=2179.diff
>
>
> Junit is currently a compile-scope dependency of configadmin. It doesn't need to be.
 This is confusing to a system that attempts to assemble runtime bundle dependencies that
will work with a bundle from maven dependencies.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message