felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Meschberger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FELIX-2123) Latest commit to ConfigurationRender is not OSGi/Minumum-1.0 compatible
Date Wed, 03 Mar 2010 10:28:27 GMT

    [ https://issues.apache.org/jira/browse/FELIX-2123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12840568#action_12840568
] 

Felix Meschberger commented on FELIX-2123:
------------------------------------------

The problem with using the old signature is, that it almost certainly will break on non-UTF-8
platforms. How about this:

    try {
        URLDecoder.decode(String, String);
    catch (NoSuchMethodError) {
        URLDecoder.decode(String);
    }

WDYT ?

> Latest commit to ConfigurationRender is not OSGi/Minumum-1.0 compatible
> -----------------------------------------------------------------------
>
>                 Key: FELIX-2123
>                 URL: https://issues.apache.org/jira/browse/FELIX-2123
>             Project: Felix
>          Issue Type: Bug
>          Components: Web Console
>            Reporter: Valentin Valchev
>            Assignee: Felix Meschberger
>
> The method URLDecoder.decode( String, String ) is not available in Minumum EE. This is
the reason for using the old, deprecated URLDecoder.decode( String ) method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message