felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FELIX-2127) The explanation given why a resource is include is insufficient
Date Fri, 26 Feb 2010 16:19:27 GMT

     [ https://issues.apache.org/jira/browse/FELIX-2127?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Guillaume Nodet updated FELIX-2127:
-----------------------------------

    Summary: The explanation given why a resource is include is insufficient  (was: The explanation given why a resource is include is nearly useless)

> The explanation given why a resource is include is insufficient
> ---------------------------------------------------------------
>
>                 Key: FELIX-2127
>                 URL: https://issues.apache.org/jira/browse/FELIX-2127
>             Project: Felix
>          Issue Type: Improvement
>          Components: Bundle Repository (OBR)
>            Reporter: Guillaume Nodet
>            Assignee: Guillaume Nodet
>             Fix For: bundlerepository-1.6.0
>
>
> Here's the output from a resolution:
> {code}
> Required resource(s):
> ---------------------
>    geronimo-j2ee-management_1.1_spec (1.0.1)
>       - package:(&(package=javax.management.j2ee)(version>=1.1.0))
>       - package:(&(package=javax.management.j2ee.statistics)(version>=1.1.0))
>       - package:(&(package=javax.management.j2ee.statistics)(version>=1.1.0)(!(version>=1.2.0)))
>    activemq-core (5.4.0.SNAPSHOT)
>       - bundle:(symbolicname=org.apache.activemq.activemq-core)
>    kahadb (5.4.0.SNAPSHOT)
>       - package:(&(package=org.apache.kahadb.index)(version>=5.4.0)(!(version>=5.5.0)))
>       - package:(&(package=org.apache.kahadb.journal)(version>=5.4.0)(!(version>=5.5.0)))
>       - package:(&(package=org.apache.kahadb.page)(version>=5.4.0)(!(version>=5.5.0)))
>       - package:(&(package=org.apache.kahadb.util)(version>=5.4.0)(!(version>=5.5.0)))
>    Apache ServiceMix Specs :: JSR250 1.0 (1.5.0.SNAPSHOT)
>       - package:(&(package=javax.annotation)(version>=1.0.0))
>       - package:(&(package=javax.annotation.security)(version>=1.0.0))
>       - package:(&(package=javax.annotation)(version>=1.0.0)(!(version>=1.1.0)))
>       - package:(&(package=javax.annotation)(version>=1.0.0)(!(version>=2.0.0)))
>    geronimo-jms_1.1_spec (1.1.1)
>       - package:(&(package=javax.jms)(version>=1.1.0))
>       - package:(&(package=javax.jms)(version>=1.1.0)(!(version>=1.2.0)))
>       - package:(&(package=javax.jms)(version>=1.1.0)(!(version>=2.0.0)))
> Optional resource(s):
> ---------------------
>    Apache XBean :: Spring (3.6.0)
>       - package:(&(package=org.apache.xbean.spring)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.context)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.context.impl)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.context.v2)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.context.v2c)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.generator)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.jndi)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.util)(version>=3.6.0))
>       - package:(&(package=org.apache.xbean.spring.context)(version>=3.6.0)(!(version>=3.7.0)))
>       - package:(&(package=org.apache.xbean.spring.context.impl)(version>=3.6.0)(!(version>=3.7.0)))
>       - package:(&(package=org.apache.xbean.spring.context.v2)(version>=0.0.0))
>    Apache ServiceMix Bundles: mail-1.4.1 (1.4.1.2)
>       - package:(&(package=javax.mail)(version>=1.4.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.mail.internet)(version>=1.4.0)(!(version>=2.0.0)))
>    activeio-core (3.1.2)
>       - package:(&(package=org.apache.activeio.adapter)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.journal)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.journal.active)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.journal.howl)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.oneport)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.packet)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.xnet)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.xnet.hba)(version>=3.1.2))
>       - package:(&(package=org.apache.activeio.journal)(version>=3.1.0)(!(version>=3.2.0)))
>       - package:(&(package=org.apache.activeio.journal.active)(version>=3.1.0)(!(version>=3.2.0)))
>       - package:(&(package=org.apache.activeio.packet)(version>=3.1.0)(!(version>=3.2.0)))
>    osgi.cmpn (4.2.0.200908310645)
>       - package:(&(package=info.dmtree)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=info.dmtree.notification)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=info.dmtree.notification.spi)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=info.dmtree.registry)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=info.dmtree.security)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=info.dmtree.spi)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.application)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.application)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.blueprint.container)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.blueprint.reflect)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.cm)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.component)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.deploymentadmin)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.deploymentadmin.spi)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.device)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.event)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.http)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.io)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.metatype)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.monitor)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.prefs)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.provisioning)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.upnp)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.useradmin)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.wireadmin)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.cdma)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.gsm)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.measurement)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.mobile)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.position)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.tracker)(version>=1.4.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.xml)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.event)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.tracker)(version>=1.4.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.event)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.log)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.tracker)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.blueprint.reflect)(version>=1.0.0))
>       - package:(&(package=org.osgi.service.cm)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.prefs)(version>=0.0.0))
>       - package:(&(package=org.osgi.service.cm)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.http)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.tracker)(version>=0.0.0))
>       - package:(&(package=org.osgi.service.blueprint.container)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.blueprint.reflect)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.util.tracker)(version>=0.0.0))
>       - package:(&(package=org.osgi.service.cm)(version>=1.2.0))
>    Apache ServiceMix Bundles: jruby-1.1.2 (1.1.2.1)
>       - package:(&(package=builtin)(version>=1.1.2))
>       - package:(&(package=builtin.core_ext)(version>=1.1.2))
>       - package:(&(package=builtin.java)(version>=1.1.2))
>       - package:(&(package=builtin.javasupport)(version>=1.1.2))
>       - package:(&(package=builtin.javasupport.core_ext)(version>=1.1.2))
>       - package:(&(package=builtin.javasupport.proxy)(version>=1.1.2))
>       - package:(&(package=builtin.javasupport.utilities)(version>=1.1.2))
>       - package:(&(package=builtin.yaml)(version>=1.1.2))
>       - package:(&(package=com.sun.jna)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.darwin)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.freebsd-amd64)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.freebsd-i386)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.linux-amd64)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.linux-i386)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.ptr)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.sunos-amd64)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.sunos-sparc)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.sunos-sparcv9)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.sunos-x86)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.win32)(version>=1.1.2))
>       - package:(&(package=com.sun.jna.win32-x86)(version>=1.1.2))
>       - package:(&(package=jline)(version>=1.1.2))
>       - package:(&(package=jruby)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm.commons)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm.signature)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm.tree)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm.tree.analysis)(version>=1.1.2))
>       - package:(&(package=jruby.objectweb.asm.util)(version>=1.1.2))
>       - package:(&(package=org.joda.time)(version>=1.1.2))
>       - package:(&(package=org.joda.time.base)(version>=1.1.2))
>       - package:(&(package=org.joda.time.chrono)(version>=1.1.2))
>       - package:(&(package=org.joda.time.convert)(version>=1.1.2))
>       - package:(&(package=org.joda.time.field)(version>=1.1.2))
>       - package:(&(package=org.joda.time.format)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Africa)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.America)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.America.Argentina)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.America.Indiana)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.America.Kentucky)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.America.North_Dakota)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Antarctica)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Asia)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Atlantic)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Australia)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Etc)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Europe)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Indian)(version>=1.1.2))
>       - package:(&(package=org.joda.time.tz.data.Pacific)(version>=1.1.2))
>       - package:(&(package=org.joni)(version>=1.1.2))
>       - package:(&(package=org.joni.ast)(version>=1.1.2))
>       - package:(&(package=org.joni.bench)(version>=1.1.2))
>       - package:(&(package=org.joni.constants)(version>=1.1.2))
>       - package:(&(package=org.joni.encoding)(version>=1.1.2))
>       - package:(&(package=org.joni.encoding.specific)(version>=1.1.2))
>       - package:(&(package=org.joni.encoding.unicode)(version>=1.1.2))
>       - package:(&(package=org.joni.exception)(version>=1.1.2))
>       - package:(&(package=org.joni.util)(version>=1.1.2))
>       - package:(&(package=org.jruby)(version>=1.1.2))
>       - package:(&(package=org.jruby.anno)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.executable)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.types)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.util)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.visitor)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.visitor.rewriter)(version>=1.1.2))
>       - package:(&(package=org.jruby.ast.visitor.rewriter.utils)(version>=1.1.2))
>       - package:(&(package=org.jruby.common)(version>=1.1.2))
>       - package:(&(package=org.jruby.compiler)(version>=1.1.2))
>       - package:(&(package=org.jruby.compiler.impl)(version>=1.1.2))
>       - package:(&(package=org.jruby.compiler.util)(version>=1.1.2))
>       - package:(&(package=org.jruby.compiler.yarv)(version>=1.1.2))
>       - package:(&(package=org.jruby.demo)(version>=1.1.2))
>       - package:(&(package=org.jruby.environment)(version>=1.1.2))
>       - package:(&(package=org.jruby.evaluator)(version>=1.1.2))
>       - package:(&(package=org.jruby.exceptions)(version>=1.1.2))
>       - package:(&(package=org.jruby.ext)(version>=1.1.2))
>       - package:(&(package=org.jruby.ext.posix)(version>=1.1.2))
>       - package:(&(package=org.jruby.ext.posix.util)(version>=1.1.2))
>       - package:(&(package=org.jruby.ext.socket)(version>=1.1.2))
>       - package:(&(package=org.jruby.internal.runtime)(version>=1.1.2))
>       - package:(&(package=org.jruby.internal.runtime.methods)(version>=1.1.2))
>       - package:(&(package=org.jruby.java)(version>=1.1.2))
>       - package:(&(package=org.jruby.javasupport)(version>=1.1.2))
>       - package:(&(package=org.jruby.javasupport.bsf)(version>=1.1.2))
>       - package:(&(package=org.jruby.javasupport.proxy)(version>=1.1.2))
>       - package:(&(package=org.jruby.javasupport.util)(version>=1.1.2))
>       - package:(&(package=org.jruby.lexer.yacc)(version>=1.1.2))
>       - package:(&(package=org.jruby.libraries)(version>=1.1.2))
>       - package:(&(package=org.jruby.parser)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.builtin)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.callback)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.component)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.load)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.marshal)(version>=1.1.2))
>       - package:(&(package=org.jruby.runtime.scope)(version>=1.1.2))
>       - package:(&(package=org.jruby.util)(version>=1.1.2))
>       - package:(&(package=org.jruby.util.collections)(version>=1.1.2))
>       - package:(&(package=org.jruby.util.io)(version>=1.1.2))
>       - package:(&(package=org.jruby.util.string)(version>=1.1.2))
>       - package:(&(package=org.jruby.yaml)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb.events)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb.exceptions)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb.nodes)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb.tokens)(version>=1.1.2))
>       - package:(&(package=org.jvyamlb.util)(version>=1.1.2))
>       - package:(&(package=com.sun.jna)(version>=0.0.0))
>       - package:(&(package=com.sun.jna.ptr)(version>=0.0.0))
>       - package:(&(package=com.sun.jna.win32)(version>=0.0.0))
>       - package:(&(package=org.jruby)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.jruby.ast)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.jruby.exceptions)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.jruby.javasupport)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.jruby.runtime)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.jruby.runtime.builtin)(version>=1.1.0)(!(version>=2.0.0)))
>    Apache ServiceMix Bundles: xalan-2.7.1 (2.7.1.2)
>       - package:(&(package=org.apache.xpath)(version>=0.0.0))
>       - package:(&(package=org.apache.xpath.objects)(version>=0.0.0))
>    Apache ServiceMix Bundles: xmlresolver-1.2 (1.2.0.1)
>       - package:(&(package=org.apache.xml.resolver)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver.apps)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver.etc)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver.helpers)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver.readers)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver.tools)(version>=1.2.0))
>       - package:(&(package=org.apache.xml.resolver)(version>=1.2.0)(!(version>=1.3.0)))
>       - package:(&(package=org.apache.xml.resolver.readers)(version>=1.2.0)(!(version>=1.3.0)))
>    Spring Context (2.5.6.SEC01)
>       - package:(&(package=org.springframework.context)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.context.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.jndi)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.scheduling)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.stereotype)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.context)(version>=2.5.0))
>       - package:(&(package=org.springframework.context.support)(version>=2.5.0))
>       - package:(&(package=org.springframework.context)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.jndi)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.context)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.context.event)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.context.support)(version>=2.5.6)(!(version>=4.0.0)))
>    javax.ejb API v.3.1 (3.0.0.b59)
>       - package:(&(package=javax.ejb)(version>=3.1.0))
>       - package:(&(package=javax.ejb.embeddable)(version>=3.1.0))
>       - package:(&(package=javax.ejb.spi)(version>=3.1.0))
>       - package:(&(package=javax.interceptor)(version>=3.1.0))
>       - package:(&(package=javax.ejb)(version>=3.0.0)(!(version>=4.0.0)))
>       - package:(&(package=javax.interceptor)(version>=3.0.0)(!(version>=4.0.0)))
>       - package:(&(package=javax.xml.rpc.handler)(version>=1.1.0))
>       - package:(&(package=javax.ejb)(version>=0.0.0))
>    Apache ServiceMix Bundles: commons-httpclient-3.1 (3.1.0.1)
>       - package:(&(package=org.apache.commons.httpclient)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.auth)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.cookie)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.methods)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.methods.multipart)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.params)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.protocol)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient.util)(version>=3.1.0))
>       - package:(&(package=org.apache.commons.httpclient)(version>=3.1.0)(!(version>=4.0.0)))
>       - package:(&(package=org.apache.commons.httpclient.methods)(version>=3.1.0)(!(version>=4.0.0)))
>       - package:(&(package=org.apache.commons.httpclient.params)(version>=3.1.0)(!(version>=4.0.0)))
>    Apache ServiceMix Bundles: antlr-2.7.7 (2.7.7.2)
>       - package:(&(package=antlr)(version>=2.7.6)(!(version>=3.0.0)))
>       - package:(&(package=antlr.collections)(version>=2.7.6)(!(version>=3.0.0)))
>       - package:(&(package=antlr.collections.impl)(version>=2.7.6)(!(version>=3.0.0)))
>       - package:(&(package=antlr.debug.misc)(version>=2.7.6)(!(version>=3.0.0)))
>    Apache ServiceMix Bundles: asm-2.2.3 (2.2.3.1)
>       - package:(&(package=org.objectweb.asm)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.attrs)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.commons)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.signature)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.tree)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.tree.analysis)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.util)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.util.attrs)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm.xml)(version>=2.2.3))
>       - package:(&(package=org.objectweb.asm)(version>=2.2.0)(!(version>=3.0.0)))
>       - package:(&(package=org.objectweb.asm.tree)(version>=2.2.0)(!(version>=3.0.0)))
>       - package:(&(package=org.objectweb.asm.tree.analysis)(version>=2.2.0)(!(version>=3.0.0)))
>       - package:(&(package=org.objectweb.asm.util)(version>=2.2.0)(!(version>=3.0.0)))
>    Apache ServiceMix Bundles: commons-codec-1.3 (1.3.0.2)
>       - package:(&(package=org.apache.commons.codec)(version>=0.0.0))
>       - package:(&(package=org.apache.commons.codec.binary)(version>=0.0.0))
>       - package:(&(package=org.apache.commons.codec.net)(version>=0.0.0))
>    Apache Aries Transaction (1.0.0.incubating-SNAPSHOT)
>       - package:(&(package=javax.transaction.xa)(version>=0.0.0))
>       - package:(&(package=javax.transaction)(version>=1.1.0))
>       - package:(&(package=javax.transaction.xa)(version>=1.1.0))
>       - package:(&(package=org.apache.aries.transaction.exception)(version>=0.0.0))
>       - package:(&(package=javax.transaction)(version>=1.0.1)(!(version>=2.0.0)))
>       - package:(&(package=javax.transaction.xa)(version>=1.0.1)(!(version>=2.0.0)))
>       - package:(&(package=javax.transaction)(version>=1.0.0)(!(version>=2.0.0)))
>    Apache ServiceMix Bundles: xercesImpl-2.9.1 (2.9.1.3)
>       - package:(&(package=org.apache.xerces.parsers)(version>=2.8.1)(!(version>=3.0.0)))
>       - package:(&(package=org.apache.xml.serialize)(version>=2.8.1)(!(version>=3.0.0)))
>    javax.servlet API v.3.0 (3.0.0.b66)
>       - package:(&(package=javax.servlet)(version>=3.0.0))
>       - package:(&(package=javax.servlet.annotation)(version>=3.0.0))
>       - package:(&(package=javax.servlet.descriptor)(version>=3.0.0))
>       - package:(&(package=javax.servlet.http)(version>=3.0.0))
>       - package:(&(package=javax.servlet)(version>=0.0.0))
>       - package:(&(package=javax.servlet.http)(version>=0.0.0))
>       - package:(&(package=javax.servlet)(version>=0.0.0))
>       - package:(&(package=javax.servlet.http)(version>=0.0.0))
>       - package:(&(package=javax.servlet)(version>=2.5.0))
>       - package:(&(package=javax.servlet.http)(version>=2.5.0))
>    Commons Collections (3.2.1)
>       - package:(&(package=org.apache.commons.collections)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.bag)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.bidimap)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.buffer)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.collection)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.comparators)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.functors)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.iterators)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.keyvalue)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.list)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.map)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections.set)(version>=3.2.1))
>       - package:(&(package=org.apache.commons.collections)(version>=3.2.0)(!(version>=4.0.0)))
>       - package:(&(package=org.apache.commons.collections.map)(version>=3.2.0)(!(version>=4.0.0)))
>       - package:(&(package=org.apache.commons.collections.comparators)(version>=0.0.0))
>       - package:(&(package=org.apache.commons.collections.keyvalue)(version>=0.0.0))
>       - package:(&(package=org.apache.commons.collections.list)(version>=0.0.0))
>       - package:(&(package=org.apache.commons.collections.set)(version>=0.0.0))
>    Spring Core (2.5.6.SEC01)
>       - package:(&(package=org.springframework.core)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.annotation)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.io)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.io.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.type)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.util)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.util.xml)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.task)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.task.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.type.classreading)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core.type.filter)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.metadata)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.core)(version>=2.5.0))
>       - package:(&(package=org.springframework.core.io)(version>=2.5.0))
>       - package:(&(package=org.springframework.core.io.support)(version>=2.5.0))
>       - package:(&(package=org.springframework.util)(version>=2.5.0))
>       - package:(&(package=org.springframework.util.xml)(version>=2.5.0))
>       - package:(&(package=org.springframework.core.io)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.core)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.core.enums)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.core.io)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.core.io.support)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.util)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.util.xml)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.util)(version>=2.5.0)(!(version>=2.6.0)))
>    Apache ServiceMix Bundles: ant-1.7.0 (1.7.0.1)
>       - package:(&(package=org.apache.tools.ant)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.dispatch)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.filters)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.filters.util)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.helper)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.input)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.launch)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.listener)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.loader)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs.compilers)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs.condition)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs.cvslib)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs.email)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs.rmic)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.conditions)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.mappers)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.resources)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.resources.comparators)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.resources.selectors)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.selectors)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.selectors.modifiedselector)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.types.spi)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.util)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.util.facade)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant.util.regexp)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.bzip2)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.mail)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.tar)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.zip)(version>=1.7.0))
>       - package:(&(package=org.apache.tools.ant)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant.types)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.taskdefs)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.types)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.util)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.helper)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.input)(version>=0.0.0))
>       - package:(&(package=org.apache.tools.ant.helper)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant.input)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant.listener)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant.taskdefs)(version>=1.7.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.tools.ant.util)(version>=1.7.0)(!(version>=2.0.0)))
>    Commons Net (2.0.0)
>       - package:(&(package=org.apache.commons.net)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.bsd)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.chargen)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.daytime)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.discard)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.echo)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.finger)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.ftp)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.ftp.parser)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.io)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.nntp)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.ntp)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.pop3)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.smtp)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.telnet)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.tftp)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.time)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.util)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.whois)(version>=2.0.0))
>       - package:(&(package=org.apache.commons.net.ftp)(version>=2.0.0)(!(version>=2.1.0)))
>    Annotation 1.1 (1.0.0.SNAPSHOT)
>       - package:(&(package=javax.annotation)(version>=1.1.0))
>       - package:(&(package=javax.annotation.processing)(version>=1.1.0))
>       - package:(&(package=javax.annotation.security)(version>=1.1.0))
>       - package:(&(package=javax.annotation.sql)(version>=1.1.0))
>    OPS4J Pax Web - Jetty Bundle (0.7.2)
>       - package:(&(package=javax.servlet)(version>=2.3.0)(!(version>=2.6.0)))
>       - package:(&(package=javax.servlet.http)(version>=2.3.0)(!(version>=2.6.0)))
>       - package:(&(package=javax.servlet.jsp.resources)(version>=2.3.0)(!(version>=2.6.0)))
>       - package:(&(package=javax.servlet.resources)(version>=2.3.0)(!(version>=2.6.0)))
>       - package:(&(package=org.mortbay.component)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.io)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.io.bio)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.io.nio)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.bio)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.deployer)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.handler)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.nio)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.security)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.servlet)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.jetty.webapp)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.log)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.resource)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.servlet)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.servlet.jetty)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.thread)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.util)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.util.ajax)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=org.mortbay.xml)(version>=6.1.3)(!(version>=7.0.0)))
>       - package:(&(package=javax.servlet)(version>=2.3.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.http)(version>=2.3.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.resources)(version>=2.3.0)(!(version>=3.0.0)))
>       - package:(&(package=org.ops4j.pax.web.service)(version>=0.7.2))
>       - package:(&(package=javax.servlet)(version>=2.4.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.http)(version>=2.4.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet)(version>=2.5.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.http)(version>=2.5.0)(!(version>=3.0.0)))
>    Spring AOP (2.5.6.SEC01)
>       - package:(&(package=org.springframework.aop)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.config)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.framework)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.support.annotation)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.framework.adapter)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.scope)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.target)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop.target.dynamic)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.aop)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.aop.framework)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.aop.support)(version>=2.5.6)(!(version>=4.0.0)))
>    osgi.core (4.2.0.200908310645)
>       - package:(&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.framework.hooks.service)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.framework.launch)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.condpermadmin)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.packageadmin)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.permissionadmin)(version>=1.2.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.startlevel)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.service.url)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.framework)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.osgi.framework)(version>=1.5.0))
>       - package:(&(package=org.osgi.framework)(version>=0.0.0))
>    Apache ServiceMix Specs :: ACTIVATION API 1.4 (1.4.0)
>       - package:(&(package=javax.activation)(version>=1.1.0))
>       - package:(&(package=javax.activation)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.activation)(version>=1.1.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.activation)(version>=0.0.0))
>    Apache ServiceMix Bundles: junit-4.7 (4.7.0.1)
>       - package:(&(package=junit.framework)(version>=0.0.0))
>       - package:(&(package=junit.textui)(version>=0.0.0))
>    Commons Pool (1.5.4)
>       - package:(&(package=org.apache.commons.pool)(version>=1.5.4))
>       - package:(&(package=org.apache.commons.pool.impl)(version>=1.5.4))
>       - package:(&(package=org.apache.commons.pool)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=org.apache.commons.pool.impl)(version>=1.3.0)(!(version>=2.0.0)))
>    spring-osgi-core (1.2.1)
>       - package:(&(package=org.springframework.osgi.context.support)(version>=1.2.0)(!(version>=1.3.0)))
>    spring-osgi-io (1.2.1)
>       - package:(&(package=org.springframework.osgi.io)(version>=1.2.1)(version<=1.2.1))
>    EHCache (1.6.2)
>       - package:(&(package=net.sf.ehcache)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=net.sf.ehcache.bootstrap)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=net.sf.ehcache.constructs.blocking)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=net.sf.ehcache.event)(version>=1.3.0)(!(version>=2.0.0)))
>       - package:(&(package=net.sf.ehcache.store)(version>=1.3.0)(!(version>=2.0.0)))
>    Apache ServiceMix Specs :: Scripting API 1.0 (1.4.0)
>       - package:(&(package=javax.script)(version>=1.0.0))
>       - package:(&(package=javax.script)(version>=0.0.0))
>    Apache ServiceMix Bundles: howl-1.0.1-1 (1.0.1.1_1)
>       - package:(&(package=org.objectweb.howl.log)(version>=1.0.1.1))
>       - package:(&(package=org.objectweb.howl.log.util)(version>=1.0.1.1))
>       - package:(&(package=org.objectweb.howl.log.xa)(version>=1.0.1.1))
>       - package:(&(package=org.objectweb.howl.log)(version>=0.0.0))
>    Apache ServiceMix Specs :: SAAJ API 1.3 (1.5.0.SNAPSHOT)
>       - package:(&(package=javax.xml.soap)(version>=1.3.0))
>       - package:(&(package=javax.xml.soap)(version>=1.3.0)(!(version>=2.0.0)))
>    Spring Transaction (2.5.6.SEC01)
>       - package:(&(package=org.springframework.transaction)(version>=2.5.0))
>       - package:(&(package=org.springframework.transaction.jta)(version>=2.5.0))
>       - package:(&(package=org.springframework.transaction.support)(version>=2.5.0))
>    geronimo-ws-metadata_2.0_spec (1.1.2)
>       - package:(&(package=javax.jws)(version>=2.0.0))
>       - package:(&(package=javax.jws.soap)(version>=2.0.0))
>       - package:(&(package=javax.jws)(version>=0.0.0))
>    Apache ServiceMix Branding Support (4.1.0.SNAPSHOT)
>       - package:(&(package=org.apache.felix.karaf.branding)(version>=0.0.0))
>       - package:(&(package=org.apache.felix.karaf.branding)(version>=0.0.0))
>    Apache ServiceMix Specs :: JAVA PERSISTENCE API 1.4 (1.5.0.SNAPSHOT)
>       - package:(&(package=javax.persistence)(version>=1.1.1))
>       - package:(&(package=javax.persistence.spi)(version>=1.1.1))
>       - package:(&(package=javax.persistence)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.persistence.spi)(version>=1.0.0)(!(version>=2.0.0)))
>    Groovy Runtime (1.6.3)
>       - package:(&(package=groovy.beans)(version>=1.6.3))
>       - package:(&(package=groovy.grape)(version>=1.6.3))
>       - package:(&(package=groovy.inspect)(version>=1.6.3))
>       - package:(&(package=groovy.inspect.swingui)(version>=1.6.3))
>       - package:(&(package=groovy.io)(version>=1.6.3))
>       - package:(&(package=groovy.jmx.builder)(version>=1.6.3))
>       - package:(&(package=groovy.lang)(version>=1.6.3))
>       - package:(&(package=groovy.mock.interceptor)(version>=1.6.3))
>       - package:(&(package=groovy.model)(version>=1.6.3))
>       - package:(&(package=groovy.security)(version>=1.6.3))
>       - package:(&(package=groovy.servlet)(version>=1.6.3))
>       - package:(&(package=groovy.sql)(version>=1.6.3))
>       - package:(&(package=groovy.swing)(version>=1.6.3))
>       - package:(&(package=groovy.swing.binding)(version>=1.6.3))
>       - package:(&(package=groovy.swing.factory)(version>=1.6.3))
>       - package:(&(package=groovy.swing.impl)(version>=1.6.3))
>       - package:(&(package=groovy.text)(version>=1.6.3))
>       - package:(&(package=groovy.time)(version>=1.6.3))
>       - package:(&(package=groovy.ui)(version>=1.6.3))
>       - package:(&(package=groovy.ui.icons)(version>=1.6.3))
>       - package:(&(package=groovy.ui.text)(version>=1.6.3))
>       - package:(&(package=groovy.ui.view)(version>=1.6.3))
>       - package:(&(package=groovy.util)(version>=1.6.3))
>       - package:(&(package=groovy.util.slurpersupport)(version>=1.6.3))
>       - package:(&(package=groovy.xml)(version>=1.6.3))
>       - package:(&(package=groovy.xml.dom)(version>=1.6.3))
>       - package:(&(package=groovy.xml.streamingmarkupsupport)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.ASdebug)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.actions.cpp)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.actions.csharp)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.actions.java)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.actions.python)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.build)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.collections)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.collections.impl)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.debug)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.debug.misc)(version>=1.6.3))
>       - package:(&(package=groovyjarjarantlr.preprocessor)(version>=1.6.3))
>       - package:(&(package=groovyjarjarasm.asm)(version>=1.6.3))
>       - package:(&(package=groovyjarjarasm.asm.signature)(version>=1.6.3))
>       - package:(&(package=groovyjarjarasm.asm.tree)(version>=1.6.3))
>       - package:(&(package=groovyjarjarcommonscli)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.ant)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.antlr)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.antlr.java)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.antlr.parser)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.antlr.treewalker)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.ast)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.ast.expr)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.ast.stmt)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.binding)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.bsf)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.classgen)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.control)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.control.io)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.control.messages)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.groovydoc)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.jsr223)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.reflection)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.reflection.stdclasses)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.callsite)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.dgmimpl)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.dgmimpl.arrays)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.metaclass)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.typehandling)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.runtime.wrappers)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.syntax)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.classLevel)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.packageLevel)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.topLevel)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.javac)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.shell)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.shell.commands)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.shell.util)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.tools.xml)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.transform)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.util)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.vmplugin)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.vmplugin.v4)(version>=1.6.3))
>       - package:(&(package=org.codehaus.groovy.vmplugin.v5)(version>=1.6.3))
>    OPS4J Pax Web - Jsp Support (0.7.2)
>       - package:(&(package=javax.el)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp.el)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp.resources)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp.tagext)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=org.ops4j.pax.web.jsp)(version>=0.7.2))
>       - package:(&(package=org.ops4j.pax.web.jsp)(version>=0.7.2))
>       - package:(&(package=org.ops4j.pax.web.jsp)(version>=0.7.1))
>       - package:(&(package=javax.servlet.jsp)(version>=0.0.0))
>       - package:(&(package=javax.el)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp.el)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp.tagext)(version>=2.1.0)(!(version>=3.0.0)))
>    Spring Framework (2.5.6)
>       - package:(&(package=org.aopalliance.aop)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.aopalliance.intercept)(version>=1.0.0)(!(version>=2.0.0)))
>       - package:(&(package=org.springframework.beans)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans.factory)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans.factory.config)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans.factory.parsing)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans.factory.support)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans.factory.xml)(version>=2.5.0))
>       - package:(&(package=org.springframework.web.context.support)(version>=2.5.0))
>       - package:(&(package=org.springframework.beans)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.beans.factory)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.beans.factory.xml)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.springframework.beans.propertyeditors)(version>=2.5.0)(!(version>=2.6.0)))
>       - package:(&(package=org.aopalliance.aop)(version>=0.0.0))
>       - package:(&(package=org.aopalliance.intercept)(version>=0.0.0))
>       - package:(&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.beans.factory)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.beans.factory.config)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.beans.factory.support)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.beans.factory.xml)(version>=2.5.6)(!(version>=4.0.0)))
>       - package:(&(package=org.springframework.beans.propertyeditors)(version>=2.5.6)(!(version>=4.0.0)))
>    Apache ServiceMix Bundles: cglib-2.1_3 (2.1.0.3_4)
>       - package:(&(package=net.sf.cglib.proxy)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=net.sf.cglib.asm)(version>=2.1.3)(!(version>=2.2.0)))
>       - package:(&(package=net.sf.cglib.core)(version>=2.1.3)(!(version>=2.2.0)))
>       - package:(&(package=net.sf.cglib.proxy)(version>=2.1.3)(!(version>=2.2.0)))
>       - package:(&(package=net.sf.cglib.transform.impl)(version>=2.1.3)(!(version>=2.2.0)))
>    Apache ServiceMix Bundles: bcel-5.2 (5.2.0.2)
>       - package:(&(package=org.apache.bcel.classfile)(version>=5.1.0)(!(version>=6.0.0)))
>       - package:(&(package=org.apache.bcel.generic)(version>=5.1.0)(!(version>=6.0.0)))
>       - package:(&(package=org.apache.bcel.util)(version>=5.1.0)(!(version>=6.0.0)))
>    OPS4J Pax Web - Jsp Support (0.7.1)
>       - package:(&(package=javax.el)(version>=2.1.0)(!(version>=3.0.0)))
>       - package:(&(package=javax.servlet.jsp)(version>=0.0.0))
>    Apache ServiceMix Bundles: quartz-1.6.6 (1.6.6.SNAPSHOT)
>       - package:(&(package=org.quartz)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.impl)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.impl.jdbcjobstore)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.simpl)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.spi)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.utils)(version>=1.6.0)(!(version>=2.0.0)))
>       - package:(&(package=org.quartz.xml)(version>=1.6.0)(!(version>=2.0.0)))
>    Apache ServiceMix Bundles: junit-3.8.2 (3.8.2.1)
>       - package:(&(package=junit.awtui)(version>=3.8.2))
>       - package:(&(package=junit.extensions)(version>=3.8.2))
>       - package:(&(package=junit.framework)(version>=3.8.2))
>       - package:(&(package=junit.runner)(version>=3.8.2))
>       - package:(&(package=junit.swingui)(version>=3.8.2))
>       - package:(&(package=junit.swingui.icons)(version>=3.8.2))
>       - package:(&(package=junit.textui)(version>=3.8.2))
>       - package:(&(package=junit.framework)(version>=2.8.2)(!(version>=4.0.0)))
>       - package:(&(package=junit.textui)(version>=2.8.2)(!(version>=4.0.0)))
>    Apache ServiceMix Bundles: groovy-1.5.6 (1.5.6.3)
>       - package:(&(package=groovy.lang)(version>=1.5.1)(!(version>=2.0.0)))
>       - package:(&(package=org.codehaus.groovy.control)(version>=1.5.1)(!(version>=2.0.0)))
>    Apache Derby 10.4 (10.4.2000000.689064)
>       - package:(&(package=org.apache.derby.jdbc)(version>=0.0.0))
>    Apache ServiceMix Bundles: core-3.2.3.v_686_R32x (3.2.3.2)
>       - package:(&(package=org.eclipse.jdt.core)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.compiler)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.dom)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.dom.rewrite)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.eval)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.formatter)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.jdom)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.search)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.util)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.codeassist)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.codeassist.complete)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.codeassist.impl)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.codeassist.select)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.ast)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.batch)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.classfmt)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.codegen)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.env)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.flow)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.impl)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.lookup)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.parser)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.parser.diagnose)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.problem)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.compiler.util)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.builder)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.dom.rewrite)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.eval)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.hierarchy)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.index)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.jdom)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.search)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.search.indexing)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.search.matching)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.search.processing)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.util)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.eval)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.formatter)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.formatter.align)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.formatter.comment)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.formatter.old)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.core.dom)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core)(version>=0.0.0))
>       - package:(&(package=org.eclipse.jdt.internal.core.builder)(version>=0.0.0))
>    Commons BeanUtils (1.8.0)
>       - package:(&(package=org.apache.commons.beanutils)(version>=1.8.0))
>       - package:(&(package=org.apache.commons.beanutils.converters)(version>=1.8.0))
>       - package:(&(package=org.apache.commons.beanutils.expression)(version>=1.8.0))
>       - package:(&(package=org.apache.commons.beanutils.locale)(version>=1.8.0))
>       - package:(&(package=org.apache.commons.beanutils.locale.converters)(version>=1.8.0))
>       - package:(&(package=org.apache.commons.beanutils)(version>=1.7.0)(!(version>=2.0.0)))
>    geronimo-j2ee-connector_1.5_spec (2.0.0)
>       - package:(&(package=javax.resource)(version>=1.5.0))
>       - package:(&(package=javax.resource.cci)(version>=1.5.0))
>       - package:(&(package=javax.resource.spi)(version>=1.5.0))
>       - package:(&(package=javax.resource.spi.endpoint)(version>=1.5.0))
>       - package:(&(package=javax.resource.spi.security)(version>=1.5.0))
>       - package:(&(package=javax.resource.spi.work)(version>=1.5.0))
>       - package:(&(package=javax.resource.spi)(version>=1.5.0))
>       - package:(&(package=javax.resource)(version>=1.5.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.resource.cci)(version>=1.5.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.resource.spi)(version>=1.5.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.resource.spi.endpoint)(version>=1.5.0)(!(version>=2.0.0)))
>       - package:(&(package=javax.resource.spi.work)(version>=1.5.0)(!(version>=2.0.0)))
>    Groovy Runtime (1.7.0)
>       - package:(&(package=groovy.beans)(version>=1.7.0))
>       - package:(&(package=groovy.grape)(version>=1.7.0))
>       - package:(&(package=groovy.inspect)(version>=1.7.0))
>       - package:(&(package=groovy.inspect.swingui)(version>=1.7.0))
>       - package:(&(package=groovy.io)(version>=1.7.0))
>       - package:(&(package=groovy.jmx.builder)(version>=1.7.0))
>       - package:(&(package=groovy.lang)(version>=1.7.0))
>       - package:(&(package=groovy.mock.interceptor)(version>=1.7.0))
>       - package:(&(package=groovy.model)(version>=1.7.0))
>       - package:(&(package=groovy.security)(version>=1.7.0))
>       - package:(&(package=groovy.servlet)(version>=1.7.0))
>       - package:(&(package=groovy.sql)(version>=1.7.0))
>       - package:(&(package=groovy.swing)(version>=1.7.0))
>       - package:(&(package=groovy.swing.binding)(version>=1.7.0))
>       - package:(&(package=groovy.swing.factory)(version>=1.7.0))
>       - package:(&(package=groovy.swing.impl)(version>=1.7.0))
>       - package:(&(package=groovy.text)(version>=1.7.0))
>       - package:(&(package=groovy.time)(version>=1.7.0))
>       - package:(&(package=groovy.ui)(version>=1.7.0))
>       - package:(&(package=groovy.ui.icons)(version>=1.7.0))
>       - package:(&(package=groovy.ui.text)(version>=1.7.0))
>       - package:(&(package=groovy.ui.view)(version>=1.7.0))
>       - package:(&(package=groovy.util)(version>=1.7.0))
>       - package:(&(package=groovy.util.slurpersupport)(version>=1.7.0))
>       - package:(&(package=groovy.xml)(version>=1.7.0))
>       - package:(&(package=groovy.xml.dom)(version>=1.7.0))
>       - package:(&(package=groovy.xml.streamingmarkupsupport)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.ASdebug)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.actions.cpp)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.actions.csharp)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.actions.java)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.actions.python)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.build)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.collections)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.collections.impl)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.debug)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.debug.misc)(version>=1.7.0))
>       - package:(&(package=groovyjarjarantlr.preprocessor)(version>=1.7.0))
>       - package:(&(package=groovyjarjarasm.asm)(version>=1.7.0))
>       - package:(&(package=groovyjarjarasm.asm.commons)(version>=1.7.0))
>       - package:(&(package=groovyjarjarasm.asm.signature)(version>=1.7.0))
>       - package:(&(package=groovyjarjarasm.asm.tree)(version>=1.7.0))
>       - package:(&(package=groovyjarjarcommonscli)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.ant)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.antlr)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.antlr.java)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.antlr.parser)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.antlr.treewalker)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.ast)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.ast.builder)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.ast.expr)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.ast.stmt)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.binding)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.bsf)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.classgen)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.control)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.control.io)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.control.messages)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.groovydoc)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.jsr223)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.reflection)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.reflection.stdclasses)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.callsite)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.dgmimpl)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.dgmimpl.arrays)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.metaclass)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.typehandling)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.runtime.wrappers)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.syntax)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.classLevel)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.packageLevel)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.groovydoc.gstringTemplates.topLevel)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.gse)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.javac)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.shell)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.shell.commands)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.shell.util)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.tools.xml)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.transform)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.transform.powerassert)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.util)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.vmplugin)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.vmplugin.v4)(version>=1.7.0))
>       - package:(&(package=org.codehaus.groovy.vmplugin.v5)(version>=1.7.0))
>    Spring Beans (2.5.6.SEC01)
>       - package:(&(package=org.springframework.beans)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.config)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.parsing)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.xml)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.propertyeditors)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.annotation)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.access)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.factory.annotation)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
>       - package:(&(package=org.springframework.beans.support)(version>=2.5.6.SEC01)(version<=2.5.6.SEC01))
> {code}
> The reasons are merely a list of the exported packages which does not help at all.
> I think what would be usefull is a graph of dependencies instead, something like:
> {code}
> [INFO] org.apache.servicemix.nmr:org.apache.servicemix.nmr.osgi:bundle:1.1.0-SNAPSHOT
> [INFO] +- org.apache.servicemix.nmr:org.apache.servicemix.nmr.api:jar:1.1.0-SNAPSHOT:compile
> [INFO] +- org.apache.servicemix.nmr:org.apache.servicemix.nmr.core:jar:1.1.0-SNAPSHOT:compile
> [INFO] |  +- org.apache.felix:org.apache.felix.framework:jar:2.0.3:compile
> [INFO] |  |  +- org.osgi:org.osgi.core:jar:4.2.0:compile
> [INFO] |  |  \- org.osgi:org.osgi.compendium:jar:4.2.0:compile
> [INFO] |  +- org.apache.servicemix:servicemix-utils:jar:1.2.0:compile
> [INFO] |  |  +- org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1:compile
> [INFO] |  |  +- org.codehaus.woodstox:wstx-asl:jar:3.2.6:compile
> [INFO] |  |  \- org.apache.servicemix.specs:org.apache.servicemix.specs.jbi-api-1.0:jar:1.4.0:compile (version managed from 1.1.0)
> [INFO] |  |     \- org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2:compile
> [INFO] |  \- org.springframework.osgi:spring-osgi-test:jar:1.2.0:compile
> [INFO] +- org.apache.servicemix.nmr:org.apache.servicemix.nmr.spring:jar:1.1.0-SNAPSHOT:compile
> [INFO] |  \- org.springframework.osgi:spring-osgi-core:jar:1.2.0:compile
> [INFO] |     +- org.springframework.osgi:spring-osgi-io:jar:1.2.0:compile
> [INFO] |     +- org.springframework:org.springframework.aop:jar:2.5.6.A:compile
> [INFO] |     +- org.springframework:org.springframework.beans:jar:2.5.6.A:compile
> [INFO] |     +- org.springframework:org.springframework.context:jar:2.5.6.A:compile
> [INFO] |     \- org.springframework:org.springframework.core:jar:2.5.6.A:compile
> [INFO] +- org.apache.geronimo.blueprint:geronimo-blueprint:jar:1.0.0:compile
> [INFO] |  \- org.slf4j:slf4j-api:jar:1.5.6:compile
> [INFO] +- org.apache.felix:org.osgi.core:jar:1.4.0:provided
> [INFO] +- org.apache.felix:org.osgi.compendium:jar:1.4.0:provided
> [INFO] +- org.apache.servicemix.bundles:org.apache.servicemix.bundles.junit:jar:3.8.2_1:test
> [INFO] +- commons-logging:commons-logging:jar:1.1.1:test (scope not updated to compile)
> [INFO] \- org.fusesource.commonman:commons-management:jar:1.0:compile
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message