felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jackson, Bruce" <bru...@qualcomm.com>
Subject Re: Felix under 1.5 and Jetty
Date Tue, 26 Jan 2010 06:19:16 GMT
Its not just Jetty that I see this problem with (although to answer your
question, yes its Jetty 6), it seems to be with the framework too. I'm new
to building this from source, so I just followed the instructions at:


My default JDK is:

brucej$ java -version
java version "1.6.0_17"
Java(TM) SE Runtime Environment (build 1.6.0_17-b04-248-10M3025)
Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01-101, mixed mode)

...so I expected this to build under the JDK 6 compiler. However, whatever I
seem to do, when I look at the felix.jar in main/bin and unjar it, the
compiled classes seem to have been built under JDK 1.4. For example:

brucej$ javap -verbose -classpath . BundleContextImpl
Compiled from "BundleContextImpl.java"
class org.apache.felix.framework.BundleContextImpl extends java.lang.Object
implements org.apache.felix.framework.ext.FelixBundleContext
  SourceFile: "BundleContextImpl.java"
  minor version: 0
  major version: 47

What I think I should see is:
major version: 48 = Java SE 1.4.2
major version: 49 = Java SE 5
major version: 50 = Java SE 6

Any ideas what I'm doing wrong would be greatly appreciated.

On 25/01/2010 21:32, "Rob Walker" <robw@ascert.com> wrote:

> Strange - is this the new Jetty6 based bundle, or the older original
> Jetty bundle?
> The reason I ask is that we updated and built a full Feilx build a week
> or so back under JDK 1.6.0_18 and it built and runs fine?
> Didn't do anything special - just updated my SVN and rebuilt
> - Rob
> Jackson, Bruce wrote:
>> On further investigation, I can't get the main/framework of felix to build
>> using a 1.5 (or greater) compiler. Is there a top level switch for the
>> compiler version which I'm just missing? Does felix default to 1.4.2 for a
>> reason?
>> Thanks
>> Bruce

View raw message