felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Custine <chris.cust...@gmail.com>
Subject Re: Felix under 1.5 and Jetty
Date Fri, 22 Jan 2010 16:48:58 GMT
Just add this to the plugins section of the pom.xml:

      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>1.5</source>
          <target>1.5</target>
        </configuration>
      </plugin>

Looks like almost all modules already do this individually, so this should
probably be moved to the parent at some point.

Chris
--
Chris Custine
FUSESource :: http://fusesource.com
My Blog :: http://blog.organicelement.com
Apache ServiceMix :: http://servicemix.apache.org
Apache Felix :: http://felix.apache.org
Apache Directory Server :: http://directory.apache.org


On Fri, Jan 22, 2010 at 9:41 AM, Jackson, Bruce <brucej@qualcomm.com> wrote:

> Hi All
>
> I've just checked out and built the latest version of Felix from svn as per
> the instructions at:
>
> http://felix.apache.org/site/building-felix.html
>
> When I look at the final compiled
> org.apache.felix.http.jetty-2.0.5-SNAPSHOT.jar with javap, I see that this
> has been compiled with the 1.4 compiler i.e. javap -verbose gives me:
>
> minor version: 0
> major version: 48
>
> I've tried to locate where this is set in the POM files, but does anyone
> happen to know how I can change this to compile under 1.5/1.6?
>
> Thanks
>
> Bruce
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message