felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valentin Valchev (JIRA)" <j...@apache.org>
Subject [jira] Created: (FELIX-1957) Make Web Console compatible with OSGi/Minimum-1.0 EE
Date Mon, 21 Dec 2009 14:08:18 GMT
Make Web Console compatible with OSGi/Minimum-1.0 EE

                 Key: FELIX-1957
                 URL: https://issues.apache.org/jira/browse/FELIX-1957
             Project: Felix
          Issue Type: New Feature
            Reporter: Valentin Valchev

Currently the Web Console requires some methods that are JDK 1.4+ specific.
In some embedded JVM the methods are not available. 
However, it's not needed to sync with each embedded JVM but make sure to run at least at OSGi/Minimum-1.0
Execution Environment.

The problem methods are:
String.matches(pattern);   (LicenseServlet & BundlesServlet)
String.replaceAll();              (ConfigurationRender)
String.split();                        (BundleRepositoryRender)

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message