felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bulat Nigmatullin (JIRA)" <j...@apache.org>
Subject [jira] Closed: (FELIX-1909) Apache Felix on JDK7
Date Mon, 07 Dec 2009 07:33:18 GMT

     [ https://issues.apache.org/jira/browse/FELIX-1909?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bulat Nigmatullin closed FELIX-1909.
------------------------------------

    Resolution: Not A Problem

Thank you for help!

> Apache Felix on JDK7 
> ---------------------
>
>                 Key: FELIX-1909
>                 URL: https://issues.apache.org/jira/browse/FELIX-1909
>             Project: Felix
>          Issue Type: Bug
>          Components: Main
>    Affects Versions: felix-2.0.2
>         Environment: Ubuntu Linux 9.04 64-bit
> java version "1.7.0-ea"
> Java(TM) SE Runtime Environment (build 1.7.0-ea-b76)
> Java HotSpot(TM) 64-Bit Server VM (build 17.0-b05, mixed mode)
>            Reporter: Bulat Nigmatullin
>            Priority: Minor
>         Attachments: config.properties, stdout.log
>
>
> I tried to start our OSGi application on JDK7, but got a lot of errors like this
> Unresolved constraint in bundle javax.mail.mail [20]: package; (package=javax.activation)
> I've modified Apache Felix config.properties:
> org.osgi.framework.system.packages.extra= \
>   javax.activation; \
>   javax.crypto; \
>   javax.crypto.interfaces; \
>   javax.crypto.spec; \
>   javax.management; \
>   javax.naming; \
>   javax.naming.directory; \
>   javax.naming.spi; \
>   javax.net; \
>   javax.net.ssl; \
>   javax.security.auth; \
>   javax.security.auth.callback; \
>   javax.security.auth.x500; \
>   javax.security.cert; \
>   javax.security.sasl; \
>   javax.sql; \
>   javax.swing; \
>   javax.swing.border; \
>   javax.swing.event; \
>   javax.swing.plaf; \
>   javax.swing.plaf.basic; \
>   javax.swing.table; \
>   javax.swing.text; \
>   javax.swing.tree; \
>   javax.xml.namespace; \
>   javax.xml.parsers; \
>   javax.xml.stream; \
>   javax.xml.transform; \
>   javax.xml.transform.dom; \
>   javax.xml.transform.stream; \
>   org.ietf.jgss; \
>   org.xml.sax; \
>   org.xml.sax.helpers; \
>   org.w3c.dom;
> But one error remained:
> org.osgi.framework.BundleException: Unresolved constraint in bundle com.springsource.org.dom4j
[18]: package; (&(package=javax.xml.stream)(version>=1.0.1)(!(version>=2.0.0)))
> My application work on JDK6 without all that extra packages. But now Felix requires them.
Is this behaviour correct?
> How to fix this javax.xml.stream import?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message