felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Pauls (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (FELIX-1101) framework.security can't be built or run against Felix 1.6
Date Tue, 24 Nov 2009 23:25:39 GMT

     [ https://issues.apache.org/jira/browse/FELIX-1101?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Pauls resolved FELIX-1101.
-------------------------------

    Resolution: Fixed

I did migrate the security provider to felix 2.0.2 as of revision 883923.

> framework.security can't be built or run against Felix 1.6
> ----------------------------------------------------------
>
>                 Key: FELIX-1101
>                 URL: https://issues.apache.org/jira/browse/FELIX-1101
>             Project: Felix
>          Issue Type: Bug
>          Components: Conditional Permission Admin, Permission Admin
>    Affects Versions: felix-1.6.0
>            Reporter: Ulf Dittmer
>            Assignee: Karl Pauls
>         Attachments: framework-security.zip, security.diff
>
>
> The org.apache.felix.framework.SecurityActivator and org.apache.felix.framework.SecurityProviderImpl
classes have a dependency on the org.apache.felix.framework.FelixBundle class, which seems
to have been removed since Felix 1.4 (which, BTW, works fine with the PermissionAdmin service).
> Most -but not all- of the required methods seem to be available in org.apache.felix.framework.BundleImpl
now. Further changes involve using IModule instead of IContentLoader.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message