felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filippo Diotalevi <filippo.diotal...@gmail.com>
Subject Re: Any race condition in Felix 1.8 service lookup you are aware of?
Date Wed, 16 Sep 2009 17:37:57 GMT
On Wed, Sep 16, 2009 at 5:16 PM, Richard S. Hall <heavy@ungoverned.org> wrote:
> Are you saying you do not experience this in Felix 2.0.0?
>
> If so, we didn't address anything specific in this area.

I haven't tried with 2.0, since the problem is very difficult to
reproduce (we actually experience it just in one machine, that we
cannot access easily).
However, I tried today a simple home made load testing (100+ threads
trying to concurrently get a reference to some appearing/disappearing
services) and both 1.8.0 and 2.0.0 showed no issues.

The only clue so far is that "services -u <pid>" in the console
clearly shows that Spring DM has injected a wrong service reference in
a Spring bean. I'll try to continue my investigation on the Spring
side.


-- 
Filippo Diotalevi

Mime
View raw message