felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Savage (JIRA)" <j...@apache.org>
Subject [jira] Created: (FELIX-1586) Framework reports org.osgi.framework.version as 1.3
Date Sun, 13 Sep 2009 10:38:57 GMT
Framework reports org.osgi.framework.version as 1.3
---------------------------------------------------

                 Key: FELIX-1586
                 URL: https://issues.apache.org/jira/browse/FELIX-1586
             Project: Felix
          Issue Type: Bug
          Components: Framework
    Affects Versions: felix-2.0.0
            Reporter: David Savage


Framework version is tested in ServiceTracker line 248 to check if the framework supports
ServiceEvent#MODIFIED_ENDMATCH which is needed in some dosgi scenarios to support ListenerHooks.
For this to work the version needs to be 1.5.0 or greater, but the constant appears to be
hard coded to 1.3 in FelixConstants?

A quick hack to change the version to 1.5 enabled the ListenerHook behaviour but unsure if
this has wider consequences?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message